summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-05-24 12:11:35 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-05-24 12:13:44 -0500
commitbc57417ab8fc26344b67634ef95cb9f1cc8b27f5 (patch)
treedca5e5235b4de0937ec4acc96365bca8d6959e04 /sys-apps/baselayout
parentprofiles: Add <app-office/libreoffice-6.0[kde] to package.use.mask (diff)
downloadgentoo-bc57417ab8fc26344b67634ef95cb9f1cc8b27f5.tar.gz
gentoo-bc57417ab8fc26344b67634ef95cb9f1cc8b27f5.tar.bz2
gentoo-bc57417ab8fc26344b67634ef95cb9f1cc8b27f5.zip
sys-apps/baselayout: sync live ebuild
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-apps/baselayout/baselayout-9999.ebuild b/sys-apps/baselayout/baselayout-9999.ebuild
index 2d016a01e5b3..866701708dc6 100644
--- a/sys-apps/baselayout/baselayout-9999.ebuild
+++ b/sys-apps/baselayout/baselayout-9999.ebuild
@@ -63,11 +63,11 @@ multilib_layout() {
# data ... just fall over in that case.
local prefix prefix_lst
if use split-usr ; then
- prefix_lst="${EROOT}"{,usr/,usr/local/}
+ prefix_lst=( "${EROOT}"{,usr/,usr/local/} )
else
- prefix_lst="${EROOT}"{usr/,usr/local/}
+ prefix_lst=( "${EROOT}"{usr/,usr/local/} )
fi
- for prefix in "${prefix_lst}"; do
+ for prefix in "${prefix_lst[@]}"; do
if [ "${SYMLINK_LIB}" = yes ] ; then
# we need to make sure "lib" points to the native libdir
if [ -h "${prefix}lib" ] ; then
@@ -258,6 +258,11 @@ pkg_postinst() {
ewarn "Please run env-update then log out and back in to"
ewarn "update your path."
fi
+ # clean up after 2.5 typos
+ # https://bugs.gentoo.org/show_bug.cgi?id=656380
+ if [[ ${x} == 2.5 ]]; then
+ rm -fr "${EROOT}{,usr"
+ fi
done
if [[ -e "${EROOT}"etc/env.d/00basic ]]; then