summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-11-04 21:03:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-11-04 21:05:50 +0000
commita8285a86a66e59238a5b3e772555b2214c0a48be (patch)
tree2eeee15800df61824ea29d05516417a15e5bdf74 /sys-apps/cpuid/cpuid-20151017.ebuild
parentnet-p2p/qbittorrent: Version bump (diff)
downloadgentoo-a8285a86a66e59238a5b3e772555b2214c0a48be.tar.gz
gentoo-a8285a86a66e59238a5b3e772555b2214c0a48be.tar.bz2
gentoo-a8285a86a66e59238a5b3e772555b2214c0a48be.zip
sys-apps/cpuid: Version bump
Package-Manager: portage-2.2.23
Diffstat (limited to 'sys-apps/cpuid/cpuid-20151017.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20151017.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20151017.ebuild b/sys-apps/cpuid/cpuid-20151017.ebuild
new file mode 100644
index 000000000000..77863be1a235
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20151017.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20150606-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-20110305-fPIC.patch #376245
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}