summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-08-10 16:49:13 +1000
committerMike Gilbert <floppym@gentoo.org>2022-09-09 11:29:24 -0400
commit5bc7797979b40ded5abf792bfbb1da20b93f917f (patch)
tree9763ea0dca13b5f42b8b513ee7287a60fbb94ab1 /sys-apps/dbus-broker/dbus-broker-32.ebuild
parentapp-emulation/open-vm-tools: add 12.1.0 (diff)
downloadgentoo-5bc7797979b40ded5abf792bfbb1da20b93f917f.tar.gz
gentoo-5bc7797979b40ded5abf792bfbb1da20b93f917f.tar.bz2
gentoo-5bc7797979b40ded5abf792bfbb1da20b93f917f.zip
sys-apps/dbus-broker: add 32
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/dbus-broker/dbus-broker-32.ebuild')
-rw-r--r--sys-apps/dbus-broker/dbus-broker-32.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/dbus-broker/dbus-broker-32.ebuild b/sys-apps/dbus-broker/dbus-broker-32.ebuild
new file mode 100644
index 000000000000..cf73e0592faf
--- /dev/null
+++ b/sys-apps/dbus-broker/dbus-broker-32.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2017-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bus1/dbus-broker.git"
+else
+ SRC_URI="https://github.com/bus1/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+DESCRIPTION="Linux D-Bus Message Broker"
+HOMEPAGE="https://github.com/bus1/dbus-broker/wiki"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="audit doc +launcher selinux"
+
+DEPEND="
+ audit? (
+ >=sys-process/audit-3.0
+ >=sys-libs/libcap-ng-0.6
+ )
+ launcher? (
+ >=dev-libs/expat-2.2
+ >=sys-apps/systemd-230:0=
+ )
+ selinux? ( >=sys-libs/libselinux-3.2 )
+"
+RDEPEND="${DEPEND}
+ launcher? ( sys-apps/dbus )"
+BDEPEND="
+ doc? ( dev-python/docutils )
+ virtual/pkgconfig
+"
+
+if [[ ${PV} == 9999 ]]; then
+src_unpack() {
+ git-r3_src_unpack
+ cd "${P}" || die
+ meson subprojects download || die
+}
+fi
+
+src_configure() {
+ local emesonargs=(
+ -Daudit=$(usex audit true false)
+ -Ddocs=$(usex doc true false)
+ -Dlauncher=$(usex launcher true false)
+ -Dselinux=$(usex selinux true false)
+ )
+ meson_src_configure
+}