summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-11 17:17:27 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-11 17:17:51 +0100
commit26b0f7b6cf3f930c8a8d9c37da1f4dfc92a97c9e (patch)
treebd79eb08065d82d0aaedbf89aa2ec813f97eed7d /sys-apps/ed/ed-1.15-r1.ebuild
parentmedia-video/smplayer: Bump to version 19.10.2. Removed old (diff)
downloadgentoo-26b0f7b6cf3f930c8a8d9c37da1f4dfc92a97c9e.tar.gz
gentoo-26b0f7b6cf3f930c8a8d9c37da1f4dfc92a97c9e.tar.bz2
gentoo-26b0f7b6cf3f930c8a8d9c37da1f4dfc92a97c9e.zip
sys-apps/ed: rev bump
- EAPI bumped to EAPI=7 - Do not use econf Closes: https://bugs.gentoo.org/611068 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/ed/ed-1.15-r1.ebuild')
-rw-r--r--sys-apps/ed/ed-1.15-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/ed/ed-1.15-r1.ebuild b/sys-apps/ed/ed-1.15-r1.ebuild
new file mode 100644
index 000000000000..0226fe03f9c2
--- /dev/null
+++ b/sys-apps/ed/ed-1.15-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="https://www.gnu.org/software/ed/"
+#SRC_URI="mirror://gnu/ed/${P}.tar.lz"
+# Using gzip instead -- the filesize diff is small and lzip uncommon #545344
+SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+src_configure() {
+ # Upstream configure script is moronic.
+ ./configure \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin" \
+ --prefix="${EPREFIX}/usr"
+}