summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-04 19:24:37 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-06 20:30:48 +0200
commit737fdd77262149e839a44eb97dc27a1be0751d36 (patch)
tree3bb360e5d20e9f54066f17a5be6e4229b54650c4 /sys-apps/elfix
parentsys-block/arcconf: fix install (diff)
downloadgentoo-737fdd77262149e839a44eb97dc27a1be0751d36.tar.gz
gentoo-737fdd77262149e839a44eb97dc27a1be0751d36.tar.bz2
gentoo-737fdd77262149e839a44eb97dc27a1be0751d36.zip
sys-apps/elfix: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36548 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/elfix-0.9.5-r1.ebuild45
-rw-r--r--sys-apps/elfix/elfix-9999.ebuild12
2 files changed, 50 insertions, 7 deletions
diff --git a/sys-apps/elfix/elfix-0.9.5-r1.ebuild b/sys-apps/elfix/elfix-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..b852f0585a0b
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.9.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Suite of tools to work with ELF objects on Hardened Gentoo"
+HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ https://dev.gentoo.org/~blueness/elfix/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+ptpax test +xtpax"
+REQUIRED_USE="|| ( ptpax xtpax )"
+# These only work with a properly configured PaX kernel
+RESTRICT="!test? ( test ) test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ cd doc && ./make.sh || die
+ fi
+}
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py" || die
+ econf \
+ $(use_enable test tests) \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
diff --git a/sys-apps/elfix/elfix-9999.ebuild b/sys-apps/elfix/elfix-9999.ebuild
index 05b415e1f5d3..b852f0585a0b 100644
--- a/sys-apps/elfix/elfix-9999.ebuild
+++ b/sys-apps/elfix/elfix-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
@@ -11,19 +11,17 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
+DESCRIPTION="Suite of tools to work with ELF objects on Hardened Gentoo"
HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
https://dev.gentoo.org/~blueness/elfix/"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
IUSE="+ptpax test +xtpax"
REQUIRED_USE="|| ( ptpax xtpax )"
# These only work with a properly configured PaX kernel
RESTRICT="!test? ( test ) test"
-DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
-
DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
ptpax? ( dev-libs/elfutils )
xtpax? ( sys-apps/attr )"
@@ -39,7 +37,7 @@ src_prepare() {
}
src_configure() {
- rm -f "${S}/scripts/setup.py"
+ rm -f "${S}/scripts/setup.py" || die
econf \
$(use_enable test tests) \
$(use_enable ptpax) \