summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-03-07 11:23:13 -0500
committerMike Gilbert <floppym@gentoo.org>2021-03-14 14:55:09 -0400
commit26b96a65cbf78c2c61c881fe29d6ef5f4acbec50 (patch)
treec4486d8efe0219af4b4cdac75d0e766f9b82ed51 /sys-apps/groff
parentapp-emulation/qemu: remove unused patches (diff)
downloadgentoo-26b96a65cbf78c2c61c881fe29d6ef5f4acbec50.tar.gz
gentoo-26b96a65cbf78c2c61c881fe29d6ef5f4acbec50.tar.bz2
gentoo-26b96a65cbf78c2c61c881fe29d6ef5f4acbec50.zip
sys-apps/groff: EAPI 7
Closes: https://bugs.gentoo.org/774699 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/groff-1.22.4.ebuild36
1 files changed, 17 insertions, 19 deletions
diff --git a/sys-apps/groff/groff-1.22.4.ebuild b/sys-apps/groff/groff-1.22.4.ebuild
index 562ef0a0eeba..9b743edaf3b4 100644
--- a/sys-apps/groff/groff-1.22.4.ebuild
+++ b/sys-apps/groff/groff-1.22.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -21,14 +21,15 @@ IUSE="examples uchardet X"
RDEPEND="
uchardet? ( app-i18n/uchardet )
X? (
+ x11-libs/libICE
+ x11-libs/libSM
x11-libs/libX11
- x11-libs/libXt
- x11-libs/libXmu
x11-libs/libXaw
- x11-libs/libSM
- x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libXt
)"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-lang/perl
sys-apps/texinfo"
@@ -70,16 +71,13 @@ src_configure() {
}
src_compile() {
- if tc-is-cross-compiler ; then
- local CROSS_ARGS=(
- GROFFBIN="$(type -P groff)"
- TROFFBIN="$(type -P troff)"
- GROFF_BIN_DIR=
- GROFF_BIN_PATH=
- )
- else
- unset CROSS_ARGS
- fi
+ local -a CROSS_ARGS
+ tc-is-cross-compiler && CROSS_ARGS+=(
+ GROFFBIN="$(type -P groff)"
+ TROFFBIN="$(type -P troff)"
+ GROFF_BIN_DIR=
+ GROFF_BIN_PATH=
+ )
emake AR="$(tc-getAR)" "${CROSS_ARGS[@]}"
}
@@ -93,11 +91,11 @@ src_install() {
if ! use examples ; then
# The pdf files might not be generated if ghostscript is unavailable. #602020
- local pdf="${ED%/}/usr/share/doc/${PF}/examples/mom/mom-pdf.pdf"
+ local pdf="${ED}/usr/share/doc/${PF}/examples/mom/mom-pdf.pdf"
if [[ -e ${pdf} ]] ; then
# Keep mom-pdf.pdf since it's more of a manual than an example. #454196 #516732
- mv "${pdf}" "${ED%/}"/usr/share/doc/${PF}/pdf/ || die
+ mv "${pdf}" "${ED}/usr/share/doc/${PF}/pdf/" || die
fi
- rm -rf "${ED%/}"/usr/share/doc/${PF}/examples
+ rm -rf "${ED}/usr/share/doc/${PF}/examples"
fi
}