summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-04-22 19:13:17 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-04-22 19:51:47 +0300
commitbfdb1c4306aae7e44e99145a6023d8f8e3153f96 (patch)
treeb2bf03a58bc7565fb789255401e9a69c3c3b4c38 /sys-apps/i2c-tools
parentdev-libs/libcec: enable py3.12 (diff)
downloadgentoo-bfdb1c4306aae7e44e99145a6023d8f8e3153f96.tar.gz
gentoo-bfdb1c4306aae7e44e99145a6023d8f8e3153f96.tar.bz2
gentoo-bfdb1c4306aae7e44e99145a6023d8f8e3153f96.zip
sys-apps/i2c-tools: drop 4.2
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/Manifest1
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.2.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/sys-apps/i2c-tools/Manifest b/sys-apps/i2c-tools/Manifest
index 7d5824b262f6..a632d9274602 100644
--- a/sys-apps/i2c-tools/Manifest
+++ b/sys-apps/i2c-tools/Manifest
@@ -1,2 +1 @@
-DIST i2c-tools-4.2.tar.xz 87600 BLAKE2B 89f84ad07f4c042f67c308d48a402aa9ed46352062ddad3456d048730019e099e6eef626d487d802e07b100ae2c836e9aa6b2345950ff8744cbc0fe1a22616fb SHA512 5e230be4983c5c9c5718491d3ce9ee2e6205edea75c4097735eb32a25e522e37a074ef4cb61d2492707efebf0cb1b75ff65f1b2ae8c0bc1684a169526809a096
DIST i2c-tools-4.3.tar.xz 81276 BLAKE2B c7300224c8d32785cd067b632bf0e9591f05264b1572f44aebda5f30a95164732d606710c13739ccb7899476219ceb3033beaf95b718ed7e18122f9181dc13fc SHA512 8a6cc12d927d6291b9baf407bc15807280539a7048ec5c2edf77414432eab43b28353c42bc0e45b7b481502aa4c5588def08f130d97fc275f635d1f77488f501
diff --git a/sys-apps/i2c-tools/i2c-tools-4.2.ebuild b/sys-apps/i2c-tools/i2c-tools-4.2.ebuild
deleted file mode 100644
index ed58d716a310..000000000000
--- a/sys-apps/i2c-tools/i2c-tools-4.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9,10} )
-DISTUTILS_OPTIONAL="1"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
-HOMEPAGE="https://www.kernel.org/pub/software/utils/i2c-tools"
-SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="perl python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-RDEPEND+="
- perl? ( dev-lang/perl )"
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-
- # Cut out the eeprom/ & stub/ dirs as only perl scripts live there.
- if ! use perl ; then
- sed -i '/^SRCDIRS/s: eeprom stub : :g' Makefile || die
- fi
-}
-
-src_configure() {
- use python && distutils-r1_src_configure
-
- export BUILD_DYNAMIC_LIB=1
- export USE_STATIC_LIB=0
- export BUILD_STATIC_LIB=0
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" all-lib # parallel make
- emake CC="$(tc-getCC)"
- emake -C eepromer CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-
- if use python ; then
- cd py-smbus || die
- append-cppflags -I../include
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" libdir="/usr/$(get_libdir)" PREFIX="/usr" install-lib install
- dosbin eepromer/eeprom{,er}
- dodoc CHANGES README
- local d
- for d in $(usex perl eeprom '') eepromer ; do
- docinto "${d}"
- dodoc "${d}"/README*
- done
-
- if use python ; then
- cd py-smbus || die
- docinto py-smbus
- dodoc README*
- distutils-r1_src_install
- fi
-}