summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2019-07-07 16:17:35 +0200
committerJonas Stein <jstein@gentoo.org>2019-07-07 16:18:42 +0200
commit1ab327659aeb37821ddefff614b86c367cf9a884 (patch)
treeea90fc5e961be99eb2649d9c84bac82f74c06100 /sys-apps/inxi/inxi-3.0.34.1.ebuild
parentdev-db/opendbx: Add patch to make building manpages optional (diff)
downloadgentoo-1ab327659aeb37821ddefff614b86c367cf9a884.tar.gz
gentoo-1ab327659aeb37821ddefff614b86c367cf9a884.tar.bz2
gentoo-1ab327659aeb37821ddefff614b86c367cf9a884.zip
sys-apps/inxi: Version bump
Bump to 3.0.34.1 Package-Manager: Portage-2.3.68, Repoman-2.3.14 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi/inxi-3.0.34.1.ebuild')
-rw-r--r--sys-apps/inxi/inxi-3.0.34.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-3.0.34.1.ebuild b/sys-apps/inxi/inxi-3.0.34.1.ebuild
new file mode 100644
index 000000000000..430ac49c150b
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.0.34.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}