summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /sys-apps/lmctfy
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/lmctfy')
-rw-r--r--sys-apps/lmctfy/lmctfy-0.2.0.ebuild2
-rw-r--r--sys-apps/lmctfy/lmctfy-0.3.0.ebuild2
-rw-r--r--sys-apps/lmctfy/lmctfy-0.3.1.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/lmctfy/lmctfy-0.2.0.ebuild b/sys-apps/lmctfy/lmctfy-0.2.0.ebuild
index 42165974ce90..a239974b055b 100644
--- a/sys-apps/lmctfy/lmctfy-0.2.0.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.2.0.ebuild
@@ -31,5 +31,5 @@ src_install() {
# silly upstream!
mkdir -p "${D}/usr/bin"
cp "${S}/bin/lmctfy/cli/lmctfy" "${D}/usr/bin/" || die "Failed to copy cli binary"
- dolib.a "${S}/bin/liblmctfy.a" || die "Failed to copy library"
+ dolib.a "${S}/bin/liblmctfy.a"
}
diff --git a/sys-apps/lmctfy/lmctfy-0.3.0.ebuild b/sys-apps/lmctfy/lmctfy-0.3.0.ebuild
index 42165974ce90..a239974b055b 100644
--- a/sys-apps/lmctfy/lmctfy-0.3.0.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.3.0.ebuild
@@ -31,5 +31,5 @@ src_install() {
# silly upstream!
mkdir -p "${D}/usr/bin"
cp "${S}/bin/lmctfy/cli/lmctfy" "${D}/usr/bin/" || die "Failed to copy cli binary"
- dolib.a "${S}/bin/liblmctfy.a" || die "Failed to copy library"
+ dolib.a "${S}/bin/liblmctfy.a"
}
diff --git a/sys-apps/lmctfy/lmctfy-0.3.1.ebuild b/sys-apps/lmctfy/lmctfy-0.3.1.ebuild
index 42165974ce90..a239974b055b 100644
--- a/sys-apps/lmctfy/lmctfy-0.3.1.ebuild
+++ b/sys-apps/lmctfy/lmctfy-0.3.1.ebuild
@@ -31,5 +31,5 @@ src_install() {
# silly upstream!
mkdir -p "${D}/usr/bin"
cp "${S}/bin/lmctfy/cli/lmctfy" "${D}/usr/bin/" || die "Failed to copy cli binary"
- dolib.a "${S}/bin/liblmctfy.a" || die "Failed to copy library"
+ dolib.a "${S}/bin/liblmctfy.a"
}