summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-03 23:17:25 +0000
committerSam James <sam@gentoo.org>2021-01-03 23:17:39 +0000
commit3209de1454d8885df8c78aeda492d72054feb966 (patch)
tree819dfc0f52a01353da360287898b4a72cfc87c02 /sys-apps/moreutils
parentapp-benchmarks/sysbench: add ~arm keyword (diff)
downloadgentoo-3209de1454d8885df8c78aeda492d72054feb966.tar.gz
gentoo-3209de1454d8885df8c78aeda492d72054feb966.tar.bz2
gentoo-3209de1454d8885df8c78aeda492d72054feb966.zip
sys-apps/moreutils: bump to 0.65
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moreutils')
-rw-r--r--sys-apps/moreutils/Manifest1
-rw-r--r--sys-apps/moreutils/moreutils-0.65.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/moreutils/Manifest b/sys-apps/moreutils/Manifest
index db4daa91ebce..298f4daac613 100644
--- a/sys-apps/moreutils/Manifest
+++ b/sys-apps/moreutils/Manifest
@@ -1 +1,2 @@
DIST moreutils-0.64.tar.gz 92741 BLAKE2B 3e014a18a3b7615bcd83fd9b0a1e3010a059aae154395c2c1158f57634fe83c27503dc3aff1e116743cf80fc73ee2063ea60b03d4bece4119b962669095c71dc SHA512 94f131b9b02a8c1139dfe34abacab022687f51413c529288f57fa876676c028e200324ed855b910a7dbfb4290eb8b38b3dc182eda49988f521a550162b0a0eec
+DIST moreutils-0.65.tar.gz 93180 BLAKE2B 2105cc281b9f4c9598bb0cdd5a4b9b8042e77eb14de323ba889c182c956b00d7b8a899c4112542e0a3d513fd961ee0ed6c82dd2dbefffe50e1d4fd326919ef4f SHA512 dcad2a3b6d9621da6d2f860f39acb04c80d42cc2123e12a6ec84524f6a1fc7f5ae4bd5d00e698fe14d4c5e7d491d790970ce4370c9abd1f63318d1c512f596b9
diff --git a/sys-apps/moreutils/moreutils-0.65.ebuild b/sys-apps/moreutils/moreutils-0.65.ebuild
new file mode 100644
index 000000000000..d998cee9476e
--- /dev/null
+++ b/sys-apps/moreutils/moreutils-0.65.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a collection of tools that nobody thought to write when Unix was young"
+HOMEPAGE="https://joeyh.name/code/moreutils/ https://git.joeyh.name/index.cgi/moreutils.git/"
+# Not available at time of release
+#SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
+SRC_URI="https://git.joeyh.name/index.cgi/moreutils.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-linux ~x64-macos"
+IUSE="+doc +perl"
+
+RDEPEND="
+ perl? (
+ dev-lang/perl
+ dev-perl/IPC-Run
+ dev-perl/Time-Duration
+ dev-perl/TimeDate
+ )"
+DEPEND="
+ app-admin/eselect
+ doc? (
+ dev-lang/perl
+ >=app-text/docbook2X-0.8.8-r2
+ app-text/docbook-xml-dtd:4.4
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.64-respect-env.patch"
+)
+
+src_prepare() {
+ # don't build manpages
+ if ! use doc ; then
+ sed -i -e '/^all:/s/$(MANS)//' -e '/man1/d' Makefile || die
+ fi
+
+ # don't install perl scripts
+ if ! use perl ; then
+ sed -i -e '/PERLSCRIPTS/d' Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" DOCBOOKXSL="${EPREFIX}"/usr/share/sgml/docbook/xsl-stylesheets PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" INSTALL_BIN=install install
+
+ # sys-process is more advanced than parallel from moreutils, rename it
+ if use doc; then
+ mv "${ED}"/usr/share/man/man1/{,${PN}_}parallel.1 || die
+ fi
+
+ mv "${ED}"/usr/bin/{,${PN}_}parallel || die
+}
+
+pkg_postinst() {
+ # try to make sure $EDITOR is valid for vipe (bug #604630)
+ eselect editor update
+}