summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-01-13 16:21:47 -0600
committerWilliam Hubbs <williamh@gentoo.org>2016-01-13 16:22:29 -0600
commit1b2ad137e65b890a3f3f572a1e7a968f1145961c (patch)
treeb1d092ed4b17e65604d43f5d2a769a0c1212ad6c /sys-apps/s6/s6-2.2.4.3.ebuild
parentdev-lang/execline: version bump (diff)
downloadgentoo-1b2ad137e65b890a3f3f572a1e7a968f1145961c.tar.gz
gentoo-1b2ad137e65b890a3f3f572a1e7a968f1145961c.tar.bz2
gentoo-1b2ad137e65b890a3f3f572a1e7a968f1145961c.zip
sys-apps/s6: version bump
Diffstat (limited to 'sys-apps/s6/s6-2.2.4.3.ebuild')
-rw-r--r--sys-apps/s6/s6-2.2.4.3.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/s6/s6-2.2.4.3.ebuild b/sys-apps/s6/s6-2.2.4.3.ebuild
new file mode 100644
index 000000000000..171342f9a170
--- /dev/null
+++ b/sys-apps/s6/s6-2.2.4.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="http://www.skarnet.org/software/s6/"
+SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+DEPEND=">=sys-devel/make-4.0
+ static? (
+ >=dev-lang/execline-2.1.4.5[static-libs]
+ >=dev-libs/skalibs-2.3.9.0[static-libs]
+ )
+ !static? (
+ >=dev-lang/execline-2.1.4.5
+ >=dev-libs/skalibs-2.3.9.0
+ )
+ "
+RDEPEND="
+ !static? (
+ >=dev-lang/execline-2.1.4.5
+ >=dev-libs/skalibs-2.3.9.0
+ )
+ "
+
+src_prepare()
+{
+ # Remove QA warning about LDFLAGS addition
+ sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
+}
+
+src_configure()
+{
+ econf \
+ $(use_enable !static shared) \
+ $(use_enable static allstatic) \
+ $(use_enable static) \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --dynlibdir=/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --datadir=/etc \
+ --sysdepdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/$(get_libdir) \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+}
+
+src_compile()
+{
+ emake DESTDIR="${D}"
+}
+
+src_install()
+{
+ default
+ dodoc -r examples
+ dohtml -r doc/*
+}