summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2021-08-16 23:57:24 -0400
committerJoshua Kinard <kumba@gentoo.org>2021-08-16 23:58:34 -0400
commit38cd2e8f37c164f42abaf9de696610d9053d27c1 (patch)
tree6944f1560e88b0662ced16f366f90700bb5443a7 /sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild
parentsys-boot/sgibootcd: Bump version after refactoring code (diff)
downloadgentoo-38cd2e8f37c164f42abaf9de696610d9053d27c1.tar.gz
gentoo-38cd2e8f37c164f42abaf9de696610d9053d27c1.tar.bz2
gentoo-38cd2e8f37c164f42abaf9de696610d9053d27c1.zip
sys-apps/sg3_utils: Fix a compile issue under musl libc
Fix a compile issue under musl libc where the sg_dd utility internally uses the reentrant functions srand48_r(3) and mrand48_r(3), which are glibc-specific extensions. Changed to using the portable non-reentrant versions, and sent a patch upstream, which was acknowledged by the author for the next release. Closes: https://bugs.gentoo.org/808600 Signed-off-by: Joshua Kinard <kumba@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild')
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild
index 6d84c1ba6daa..ef1bff372bc5 100644
--- a/sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild
+++ b/sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="8"
inherit multilib
@@ -18,6 +18,11 @@ IUSE="static-libs"
DEPEND="sys-devel/libtool"
RDEPEND="!sys-apps/rescan-scsi-bus"
+PATCHES=(
+ # Bug #808600
+ "${FILESDIR}"/${PN}-1.46-musl-drand48-compat.patch
+)
+
src_configure() {
econf $(use_enable static-libs static)
}