summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-11 19:37:06 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-20 13:32:16 +0200
commitfcd87f99c2ab84aae5c9cd823a76e54f3503ddcb (patch)
treebcd6c69fd9ddd55cbb19cad3d13622cb8e19d401 /sys-apps/systemd-utils/systemd-utils-253.5.ebuild
parentsys-apps/systemd: use secureboot.eclass to sign efi files (diff)
downloadgentoo-fcd87f99c2ab84aae5c9cd823a76e54f3503ddcb.tar.gz
gentoo-fcd87f99c2ab84aae5c9cd823a76e54f3503ddcb.tar.bz2
gentoo-fcd87f99c2ab84aae5c9cd823a76e54f3503ddcb.zip
sys-apps/systemd-utils: use secureboot.eclass to sign efi files
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-apps/systemd-utils/systemd-utils-253.5.ebuild')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-253.5.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-253.5.ebuild b/sys-apps/systemd-utils/systemd-utils-253.5.ebuild
index 697439c0ae54..ce13ed37ce57 100644
--- a/sys-apps/systemd-utils/systemd-utils-253.5.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-253.5.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{10..12} )
QA_PKGCONFIG_VERSION=$(ver_cut 1)
inherit bash-completion-r1 flag-o-matic linux-info meson-multilib python-any-r1
-inherit toolchain-funcs udev usr-ldscript
+inherit secureboot toolchain-funcs udev usr-ldscript
DESCRIPTION="Utilities split out from systemd for OpenRC users"
HOMEPAGE="https://systemd.io/"
@@ -113,6 +113,7 @@ pkg_setup() {
if [[ ${MERGE_TYPE} != buildonly ]] && use udev; then
linux-info_pkg_setup
fi
+ use boot && secureboot_pkg_setup
}
src_prepare() {
@@ -504,6 +505,8 @@ multilib_src_install_all() {
insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/_udevadm
fi
+
+ use boot && secureboot_auto_sign
}
add_service() {