summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-07 17:18:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-07 17:51:02 +0200
commit670fb5a86b723f13b393e6014a30cd6485bdd7c6 (patch)
treef5eb9309e3b773f7d2bab618565a398b0493d408 /sys-apps/xdg-desktop-portal
parentprofiles: Mask USE revdeps until media-video/pipewire is ready (diff)
downloadgentoo-670fb5a86b723f13b393e6014a30cd6485bdd7c6.tar.gz
gentoo-670fb5a86b723f13b393e6014a30cd6485bdd7c6.tar.bz2
gentoo-670fb5a86b723f13b393e6014a30cd6485bdd7c6.zip
sys-apps/xdg-desktop-portal: Add USE screencast
Bug: https://bugs.gentoo.org/686336 Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/metadata.xml3
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild5
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-apps/xdg-desktop-portal/metadata.xml b/sys-apps/xdg-desktop-portal/metadata.xml
index 2fdbf33d963d..bcfc8e0c39c0 100644
--- a/sys-apps/xdg-desktop-portal/metadata.xml
+++ b/sys-apps/xdg-desktop-portal/metadata.xml
@@ -5,4 +5,7 @@
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
+ <use>
+ <flag name="screencast">Enable screencast portal using <pkg>media-video/pipewire</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
index 2ae2d2c52cae..525888c09794 100644
--- a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.4.2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="doc geolocation"
+IUSE="doc geolocation screencast"
BDEPEND="
dev-util/gdbus-codegen
@@ -27,15 +27,16 @@ DEPEND="
dev-libs/glib:2[dbus]
sys-fs/fuse:0
geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( media-video/pipewire )
"
RDEPEND="${DEPEND}"
src_configure() {
local myeconfargs=(
- --disable-pipewire
--with-systemduserunitdir="$(systemd_get_userunitdir)"
$(use_enable doc docbook-docs)
$(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
)
econf "${myeconfargs[@]}"
}