summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-09-09 10:20:18 -0400
committerMike Gilbert <floppym@gentoo.org>2023-09-09 10:23:31 -0400
commit1cede461dfedc004e076758bd92e1c7830d57238 (patch)
treedc37f9584d2c76ee3f53256008ea7c15d09ced8b /sys-apps
parentsys-apps/shadow: 4.14.0-r1 add 'yescrypt' USE flag (diff)
downloadgentoo-1cede461dfedc004e076758bd92e1c7830d57238.tar.gz
gentoo-1cede461dfedc004e076758bd92e1c7830d57238.tar.bz2
gentoo-1cede461dfedc004e076758bd92e1c7830d57238.zip
sys-apps/shadow: drop the bcrypt and yescrypt USE flags
These options increase code size by a trivial amount, and do not introduce any new dependencies. Enable them unconditionally. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/shadow/metadata.xml1
-rw-r--r--sys-apps/shadow/shadow-4.14.0-r2.ebuild (renamed from sys-apps/shadow/shadow-4.14.0-r1.ebuild)6
2 files changed, 3 insertions, 4 deletions
diff --git a/sys-apps/shadow/metadata.xml b/sys-apps/shadow/metadata.xml
index 93117876c1a8..732ee860c25d 100644
--- a/sys-apps/shadow/metadata.xml
+++ b/sys-apps/shadow/metadata.xml
@@ -8,7 +8,6 @@
<use>
<flag name="bcrypt">build the bcrypt password encryption algorithm</flag>
<flag name="su">build the su program</flag>
- <flag name="yescrypt">build the yescrypt password encryption algorithm</flag>
</use>
<slots>
<subslots>Reflect ABI of libsubids.so</subslots>
diff --git a/sys-apps/shadow/shadow-4.14.0-r1.ebuild b/sys-apps/shadow/shadow-4.14.0-r2.ebuild
index 0dd9f0ccff5c..b56af87c4778 100644
--- a/sys-apps/shadow/shadow-4.14.0-r1.ebuild
+++ b/sys-apps/shadow/shadow-4.14.0-r2.ebuild
@@ -19,7 +19,7 @@ LICENSE="BSD GPL-2"
# Subslot is for libsubid's SONAME.
SLOT="0/4"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="acl audit bcrypt cracklib nls pam selinux skey split-usr su systemd xattr yescrypt"
+IUSE="acl audit cracklib nls pam selinux skey split-usr su systemd xattr"
# Taken from the man/Makefile.am file.
LANGS=( cs da de es fi fr hu id it ja ko pl pt_BR ru sv tr zh_CN zh_TW )
@@ -82,12 +82,13 @@ src_configure() {
--with-libbsd
--without-group-name-max-length
--without-tcb
+ --with-bcrypt
+ --with-yescrypt
$(use_enable nls)
# TODO: wire up upstream for elogind too
$(use_enable systemd logind)
$(use_with acl)
$(use_with audit)
- $(use_with bcrypt)
$(use_with cracklib libcrack)
$(use_with elibc_glibc nscd)
$(use_with pam libpam)
@@ -95,7 +96,6 @@ src_configure() {
$(use_with skey)
$(use_with su)
$(use_with xattr attr)
- $(use_with yescrypt)
)
econf "${myeconfargs[@]}"