summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2021-05-15 13:53:58 +0200
committerJonas Stein <jstein@gentoo.org>2021-05-15 17:50:45 +0200
commit597cc88332c4f445cfeeed59e13f514c316b0c15 (patch)
tree978f2a53a1c6bcc6a1d08321295655707f86acea /sys-apps
parentmedia-sound/pulseaudio: Drop 13.0 (r0), EAPI6-- (diff)
downloadgentoo-597cc88332c4f445cfeeed59e13f514c316b0c15.tar.gz
gentoo-597cc88332c4f445cfeeed59e13f514c316b0c15.tar.bz2
gentoo-597cc88332c4f445cfeeed59e13f514c316b0c15.zip
sys-apps/inxi: version bump to 3.3.04.1
Version bump to 3.3.04.1 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.04.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index 15f915a5b6bb..675accc6e8ba 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -3,3 +3,4 @@ DIST inxi-3.0.34.1.tar.gz 308373 BLAKE2B 290a0887a7885b040f614140a99cbd7e0a8f8b8
DIST inxi-3.0.36.1.tar.gz 311680 BLAKE2B 95c9ab57a9af50ace8fdacebb42a94017b1506a9215f8f70ff35f281dd207685d570fe257abc5446b57dd9b9a7ce28e568a4ebf9d664731dde437a6cfd64647f SHA512 1b242878b9a5180ed63dedcac7381ce41380a1bd95ba7f85bfb2c97b635fdc7700162373078963ef708fa5cd47084aa6f5c71b212042fe1acd87e01a85599296
DIST inxi-3.0.38.1.tar.gz 320672 BLAKE2B 9c486ee07db4abad47c767c2f0d27d5e7c30e6640c50062c986f36201dce5217babd487a2d8f516be2d9bc41b8a06137d94ccb560fa0996d9a660a26004ef18d SHA512 44f97474a130f2b932c0ee54658673846712305bf2fb738c293514f62df1ca2c5d11688e2557a3f6eaeb933db0fed904e818e3dda28b839baa3ac89e6385d3a2
DIST inxi-3.1.06.1.tar.gz 357819 BLAKE2B e6eb8a34807323d7f46ff029af797e3a13229813bf0cff4b8b874cd21ff1d38459e2181ddf3882b4ee0d29e8c788e2fce1c01f5c295911493292082192c56c2b SHA512 6621252048e95132cfec30e341f72f5942188f273488509614aab28e55ee9987b8f3820e1298c4d9a16b4f3464f1f270fb4c1d5e5a7bf0d2f616b4180193ab6b
+DIST inxi-3.3.04.1.tar.gz 450695 BLAKE2B 3bf2fc9296c9b1e2357e7df2edeb3df5069d48b401be793ab82bd630cfbf45fdc39d6403d851d46dfa9b8e7729da6dc07e96982941396e46493f4531bb29233c SHA512 0ffde2362c79a4269df0f4bbe439e50d24a13969a22f6e84f6caeb8cace2ee49fb075d6051211709efdc831c2f7ef37eaa38d70306bc8f1a86f8ed0dc7dea094
diff --git a/sys-apps/inxi/inxi-3.3.04.1.ebuild b/sys-apps/inxi/inxi-3.3.04.1.ebuild
new file mode 100644
index 000000000000..c608479bb8f9
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.04.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}