summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-15 19:17:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-15 19:21:54 +0200
commit5a202c48f7b89cd8fdabd919292ea96485265be2 (patch)
tree1050cea85274dfcd13545e687313d2ffb12c37de /sys-apps
parentsci-mathematics/opensmt: bump to 2.5.0 (diff)
downloadgentoo-5a202c48f7b89cd8fdabd919292ea96485265be2.tar.gz
gentoo-5a202c48f7b89cd8fdabd919292ea96485265be2.tar.bz2
gentoo-5a202c48f7b89cd8fdabd919292ea96485265be2.zip
sys-apps/system-monitoring-center: new package; add 2.10.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/metadata.xml26
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild35
3 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
new file mode 100644
index 000000000000..69cea52ceb3f
--- /dev/null
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -0,0 +1 @@
+DIST system-monitoring-center-2.10.0.tar.gz 536051 BLAKE2B 198771c8ee79359644f2760954629026ce8edb4d451c83f8a2ca179f1ef59883ccb1dc9764388e6e778f5af9e5a96997ec70553be9bfefcbed60bce8a6e936b3 SHA512 ac46956b1e8cb1a21444f047c93ead522a1f99b2b2e63f342ac79e57c377cf3e7474e70d60410f7b657c9284f78ee00f3830fdd873e5ff9d2d500343077628c9
diff --git a/sys-apps/system-monitoring-center/metadata.xml b/sys-apps/system-monitoring-center/metadata.xml
new file mode 100644
index 000000000000..eb7f5c97f740
--- /dev/null
+++ b/sys-apps/system-monitoring-center/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Features: detailed system performance and usage usage monitoring/managing
+ features: monitoring CPU, RAM, Disk, Network, GPU hardware/usage
+ information, monitoring and managing processes and services (systemd),
+ monitoring users, sensors and general system information, supports
+ PolicyKit. No need to run the application with "sudo", hardware selection
+ options (selecting CPU cores, disks, network cards, GPUs), plotting
+ performance data of multiple devices at the same time, interactive charts
+ for querying performance data on any point, option for showing processes as
+ tree or list, optimized for low CPU usage and fast start, supports ARM
+ architecture, free and open source.
+ </longdescription>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/hakandundar34coding/system-monitoring-center/master/Changes.md</changelog>
+ <bugs-to>https://gitlab.com/hakandundar34coding/system-monitoring-center/-/issues/</bugs-to>
+ <remote-id type="github">hakandundar34coding/system-monitoring-center</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild
new file mode 100644
index 000000000000..6c32b80e8b88
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ sys-apps/dmidecode
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}