summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-23 18:37:34 +0100
committerSam James <sam@gentoo.org>2021-07-23 18:38:48 +0100
commit761b2543dcb6023cbdabb7c45c17e2fb96baa3f7 (patch)
tree6aa279d90e2a5d61c0fd9c33b494a51ed718be1a /sys-apps
parentwww-plugins/chrome-binary-plugins: automated update (93.0.4577.8) (diff)
downloadgentoo-761b2543dcb6023cbdabb7c45c17e2fb96baa3f7.tar.gz
gentoo-761b2543dcb6023cbdabb7c45c17e2fb96baa3f7.tar.bz2
gentoo-761b2543dcb6023cbdabb7c45c17e2fb96baa3f7.zip
sys-apps/logwatch: add 7.5.6
Closes: https://bugs.gentoo.org/801304 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.5.6.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 8af941d07d8b..56017d640133 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1 +1,2 @@
DIST logwatch-7.5.5.tar.gz 474167 BLAKE2B 3e4183ea6dad4f415987870c555391d2a9496b4d4d894f1c06336876077b2a72e06b4e3f8d272aeb65aa5ea14f5f4d17a6f461ae54b2e50f073fef58a27a5241 SHA512 71df4d69d7e580b21dc0a0f813201822a161ada68a19c6d3f0df9c8576f22c8d43ebe90643d6184e91ee1c6628de9501896a9444ff7ad6af6fe17eba5d3573f2
+DIST logwatch-7.5.6.tar.gz 484873 BLAKE2B 18a10f7baade4650c836ad402fcb92096923e0a8b6890352916e3b514bf85fe5b5070c0a47059c68fd84624407006107332f75a5ce3164a25cfa05f28f2ec882 SHA512 fb490f5bc1bf469309ee9caa1e040d71b4332d7fb64f94865a9b5fe707a92cb10c207022ce5e279709bf3412605f67f7da11303d91aa078f680c598398aab2ab
diff --git a/sys-apps/logwatch/logwatch-7.5.6.ebuild b/sys-apps/logwatch/logwatch-7.5.6.ebuild
new file mode 100644
index 000000000000..3bc98aecc866
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.5.6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit tmpfiles
+
+PATCHES=()
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+ virtual/mta
+ virtual/mailx
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo"
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ # logwatch.pl requires cache dir (bug #607668)
+ newtmpfiles "${FILESDIR}"/logwatch.tmpfile ${PN}.conf
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ # Migration from /etc/cron.daily/logwatch -> /etc/cron.daily/00-logwatch (bug #100243)
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+
+ # Trigger cache dir creation to allow immediate use of logwatch (bug #607668)
+ tmpfiles_process ${PN}.conf
+}