summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-08-14 21:01:53 -0700
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-17 21:59:00 +0300
commit8f1e7595b04f04ffc3ea15c69f895a57ec39ad31 (patch)
treebb368abc2f86ce620461d3600d173c37da869af8 /sys-apps
parentapp-text/sigil: add 2.3.0, py3.13, add system-mathjax, drop qt5 (diff)
downloadgentoo-8f1e7595b04f04ffc3ea15c69f895a57ec39ad31.tar.gz
gentoo-8f1e7595b04f04ffc3ea15c69f895a57ec39ad31.tar.bz2
gentoo-8f1e7595b04f04ffc3ea15c69f895a57ec39ad31.zip
sys-apps/bubblewrap: add 0.10.0
Closes: https://bugs.gentoo.org/937948 Signed-off-by: Zac Medico <zmedico@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bubblewrap/Manifest1
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
index 379cbce485ef..ce0b749d1fa2 100644
--- a/sys-apps/bubblewrap/Manifest
+++ b/sys-apps/bubblewrap/Manifest
@@ -1,2 +1,3 @@
+DIST bubblewrap-0.10.0.tar.xz 119328 BLAKE2B 2b4b08409612e08c1ee7cde1dabb422cdc3e994f12ad8df94c99ad15c6355e605f73159df6ea32a54a7cf219e72c55a8ad72a73c3138f06b375fca36eff0c53e SHA512 d9e60c1999f8e205d4126cbc0680f6ee6cd316a461ad81563bc0aa606f3b257da5f36d4934b13d6ab1745aa78946224223455d44edff41d16238e8633f0eced9
DIST bubblewrap-0.8.0.tar.xz 149088 BLAKE2B 5853cf42a7ab653540ec5134866c6f2459aa101e9eea724a4f283405cbcae2beb3551b7c1a7aa93d82016d4eb0d12f9c97c47df53a6d9b589db40483696253de SHA512 1cbc33f3c834ff83f4c1808d3ec2555921277d495f903ad152cbd5065a6e100c5420b4b5c62386bb2d303eb1734e074b09625013e55e3bd8631cfb3582d70e1c
DIST bubblewrap-0.9.0.tar.xz 118984 BLAKE2B 52a4e87e502da44a25031b6d6044da7712dccb2c58a2debad9a8562fd1e48805d783bec571adc0df8880a63595825a4204ceaaa4f3df2672252c631f7fe5b0c7 SHA512 3a3af355e4fdb19a91c40020d68fd83f7c74ebef92d989c932933293758bc0175fa41220c47fe829b84ba29457a12f0e225c19afe674ecbf983b0826dbc1c878
diff --git a/sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild b/sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild
new file mode 100644
index 000000000000..f52fb2cc4958
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.10.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="selinux suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root privileges
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion=enabled
+ -Dman=enabled
+ -Dtests=false
+ -Dzsh_completion=enabled
+ $(meson_feature selinux)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/bwrap
+ fi
+}