summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-11-07 18:51:29 +0200
committerSam James <sam@gentoo.org>2024-12-12 05:10:46 +0000
commita021c3b2be30d0236220baeffe0ff8991433cc14 (patch)
treea10caa009ec85251787e176990b581249e482d12 /sys-apps
parentllvm-runtimes/compiler-rt-sanitizers: Stabilize 18.1.8-r6 x86, #946220 (diff)
downloadgentoo-a021c3b2be30d0236220baeffe0ff8991433cc14.tar.gz
gentoo-a021c3b2be30d0236220baeffe0ff8991433cc14.tar.bz2
gentoo-a021c3b2be30d0236220baeffe0ff8991433cc14.zip
sys-apps/gsmartcontrol: add 2.0.1
Bug: https://bugs.gentoo.org/886527 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/39231 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gsmartcontrol/Manifest1
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-2.0.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/Manifest b/sys-apps/gsmartcontrol/Manifest
index aea538f805bd..26eb8cb2711e 100644
--- a/sys-apps/gsmartcontrol/Manifest
+++ b/sys-apps/gsmartcontrol/Manifest
@@ -1 +1,2 @@
DIST gsmartcontrol-1.1.4.tar.bz2 691155 BLAKE2B 484452b85e848ca9d0539f9fb9e63fc60f837d5e5de1d85d6ef6340fba194ea52cb2026682b263b1391a59eee4ee846dad3863dc1f0bd00296015ddcf86dda9a SHA512 a59147f7adb76fa1cfc55198d175b38f7840c0ec07563bc020757d7609891c8f67953b87a867235821f90c52bc3c8e40a8d8a57a1429e4b75a3afb3a2ada42f1
+DIST gsmartcontrol-2.0.1.tar.gz 1456341 BLAKE2B aaeb586d13b36c37dae78856dde4b929929b45d77ec741b75a4e6cbf42b0aa3c14d3525cc6ef61472a986dcd216e97aeed92d09ef330725641111fb3964b6660 SHA512 e5c1e3981d076c61cf73b69561a51a1099a1f593d3fe892048cd3fae79c241cd5533364404d46f32d385f044dd256f5e3cc68213f82063451cf1e3fda413c541
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-2.0.1.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-2.0.1.ebuild
new file mode 100644
index 000000000000..cc3c241d5b9a
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-2.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Hard Disk Drive and SSD Health Inspection Tool"
+HOMEPAGE="https://gsmartcontrol.shaduri.dev/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ashaduri/gsmartcontrol"
+else
+ SRC_URI="
+ https://github.com/ashaduri/gsmartcontrol/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3 LGPL-3 0BSD Boost-1.0 ZLIB"
+#bundles catch2, nlohmann_json, tl_expected and whereami
+LICENSE+=" Boost-1.0 CC0-1.0 MIT || ( MIT WTFPL-2 )"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-cpp/glibmm:*
+ dev-cpp/gtkmm:3.0
+ dev-libs/libsigc++:2
+ sys-apps/smartmontools
+"
+RDEPEND="
+ ${DEPEND}
+ x11-apps/xmessage
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAPP_BUILD_EXAMPLES=OFF
+ -DAPP_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}