summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-04-10 21:27:03 -0700
committerJason Zaman <perfinion@gentoo.org>2022-04-10 21:57:52 -0700
commitabc55adc2688237eef8ce9eb5d41554418cde8ce (patch)
treeba079e37b322b3835d14968798870005ffc82721 /sys-apps
parentsys-apps/selinux-python: bump to 3.4_rc1 (diff)
downloadgentoo-abc55adc2688237eef8ce9eb5d41554418cde8ce.tar.gz
gentoo-abc55adc2688237eef8ce9eb5d41554418cde8ce.tar.bz2
gentoo-abc55adc2688237eef8ce9eb5d41554418cde8ce.zip
sys-apps/semodule-utils: bump to 3.4_rc1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/semodule-utils/Manifest1
-rw-r--r--sys-apps/semodule-utils/semodule-utils-3.4_rc1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/semodule-utils/Manifest b/sys-apps/semodule-utils/Manifest
index 567a7b4cef98..a509f1a23988 100644
--- a/sys-apps/semodule-utils/Manifest
+++ b/sys-apps/semodule-utils/Manifest
@@ -1 +1,2 @@
DIST semodule-utils-3.3.tar.gz 14268 BLAKE2B 5b03dd731c28e29b146e9f75fa7ce5151e58df1ea6598356b1ad9ee6846d2ebf7ceb57c740aa0ae4b94e0a7356180bd8e608d6a9543b48251e553036f2b2833e SHA512 76aa0c9322889c7de100f3c5789bdf27b7073827fe2af371bd50a4517baa8442f35e53f16a93227dce93da0ceb054bea7e5ee17a46fe05e06f3c2d9925cf59dc
+DIST semodule-utils-3.4-rc1.tar.gz 14270 BLAKE2B 7a0b5d060fc07ea71b71ccf2eaa6604cdc00afabaef1be8efb62a38bd401cfacd20f36af1a74324c2162b5fcdbcba6a3b3c5d98e33fccba99bc38ddfabd10ff8 SHA512 848354e95fcd6ae6be3e0ff5a32b26d78b2fbd04f463f063db796ff843dab44675eceb670f10c3ee602a6280e885ecc33242b37bb67ef77d467be030ddd4a72c
diff --git a/sys-apps/semodule-utils/semodule-utils-3.4_rc1.ebuild b/sys-apps/semodule-utils/semodule-utils-3.4_rc1.ebuild
new file mode 100644
index 000000000000..ce9f168c9c89
--- /dev/null
+++ b/sys-apps/semodule-utils/semodule-utils-3.4_rc1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-libs/libsepol-${PV}:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}