summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-12 02:45:35 +0000
committerSam James <sam@gentoo.org>2023-12-12 02:45:35 +0000
commitb0fdff8c8f3c36cded1c82d80d9d955d6da94bdf (patch)
tree06a48c815e67dca1224893d0f1dbb553cc12be2f /sys-apps
parentsys-apps/systemd: backport systemd-analyze regression fix (for git test suite) (diff)
downloadgentoo-b0fdff8c8f3c36cded1c82d80d9d955d6da94bdf.tar.gz
gentoo-b0fdff8c8f3c36cded1c82d80d9d955d6da94bdf.tar.bz2
gentoo-b0fdff8c8f3c36cded1c82d80d9d955d6da94bdf.zip
sys-apps/xdg-desktop-portal-gnome: fix modern C issue
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/files/45.1-c99.patch25
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.1-r1.ebuild49
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/files/45.1-c99.patch b/sys-apps/xdg-desktop-portal-gnome/files/45.1-c99.patch
new file mode 100644
index 000000000000..884b0d9c15a6
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/files/45.1-c99.patch
@@ -0,0 +1,25 @@
+https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/issues/112
+https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/merge_requests/134
+
+From 5fb3c0c23ccd76c6f8239bbb66c3fb1230208d5e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Luk=C3=A1=C5=A1=20Tyrychtr?= <ltyrycht@redhat.com>
+Date: Mon, 11 Dec 2023 11:36:13 +0100
+Subject: [PATCH] input-capture: Pass correct pointer type to
+ gtk_window_add_group
+
+It produced only a warning, but will be an error in the future.
+
+Fixes #112
+--- a/src/inputcapture.c
++++ b/src/inputcapture.c
+@@ -409,7 +409,7 @@ create_input_capture_dialog (GDBusMethodInvocation *invocation,
+ gtk_window_set_modal (GTK_WINDOW (dialog), TRUE);
+
+ window_group = gtk_window_group_new ();
+- gtk_window_group_add_window (window_group, dialog);
++ gtk_window_group_add_window (window_group, GTK_WINDOW (dialog));
+
+ dialog_handle = g_new0 (InputCaptureDialogHandle, 1);
+ dialog_handle->request = g_object_ref (request);
+--
+GitLab
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.1-r1.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.1-r1.ebuild
new file mode 100644
index 000000000000..e4d9f570f008
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-45.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+# Newer-than-strictly-required xdg-desktop-portal dep for hang/slowness fixes
+# https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/issues/74
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ >=gui-libs/libadwaita-1.2.0:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.17.0
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? ( dev-util/wayland-scanner )
+"
+
+PATCHES=(
+ "${FILESDIR}"/45.1-c99.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}