summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-13 21:53:45 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-13 21:53:45 +0200
commitdbf1c6f879036b833ab842f967ab37b47d30de32 (patch)
treeca942719aff3b3a88371f8146c249417bf9839b1 /sys-apps
parentdev-libs/xapian-bindings: generalize to use tc-getPKG_CONFIG (diff)
parentsys-apps/irqbalance: revbump for new service unit (diff)
downloadgentoo-dbf1c6f879036b833ab842f967ab37b47d30de32.tar.gz
gentoo-dbf1c6f879036b833ab842f967ab37b47d30de32.tar.bz2
gentoo-dbf1c6f879036b833ab842f967ab37b47d30de32.zip
sys-apps/irqbalance: Merge improvements to service unit
Pull-Request: https://github.com/gentoo/gentoo/pull/139
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/irqbalance/files/irqbalance.service.18
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild49
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/files/irqbalance.service.1 b/sys-apps/irqbalance/files/irqbalance.service.1
new file mode 100644
index 000000000000..af7a979a25d0
--- /dev/null
+++ b/sys-apps/irqbalance/files/irqbalance.service.1
@@ -0,0 +1,8 @@
+[Unit]
+Description=CPU Interrupt Balancer
+
+[Service]
+ExecStart=/usr/sbin/irqbalance --foreground
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild b/sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..4962d7b0a57f
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.0.9-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa selinux"
+
+CDEPEND="dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newinitd "${FILESDIR}"/irqbalance.init.3 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_newunit "${FILESDIR}"/irqbalance.service.1 irqbalance.service
+}