summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-05-03 23:10:51 -0400
committerMike Gilbert <floppym@gentoo.org>2022-05-03 23:12:27 -0400
commit14ae476695e9fc4d699112aee7b769d65635e971 (patch)
tree0dcab8db2fb58a9a5319b207626225ab9b8e8ffe /sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r2.ebuild
parentapp-emulation/qemu: Stabilize 7.0.0-r1 ppc64, #839765 (diff)
downloadgentoo-14ae476695e9fc4d699112aee7b769d65635e971.tar.gz
gentoo-14ae476695e9fc4d699112aee7b769d65635e971.tar.bz2
gentoo-14ae476695e9fc4d699112aee7b769d65635e971.zip
sys-auth/polkit-pkla-compat: several fixes
Pass --localstatedir=/var to configure. Drop unnecessary chown calls. Depend on acct-group/polkitd. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r2.ebuild')
-rw-r--r--sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r2.ebuild b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r2.ebuild
new file mode 100644
index 000000000000..05c4ed9e6222
--- /dev/null
+++ b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Rules for polkit to add compatibility with pklocalauthority"
+HOMEPAGE="https://pagure.io/polkit-pkla-compat"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+
+RDEPEND="
+ acct-group/polkitd
+ >=dev-libs/glib-2.30
+ >=sys-auth/polkit-0.110"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ acct-group/polkitd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --localstatedir="${EPREFIX}/var"
+}
+
+src_install() {
+ default
+ keepdir /etc/polkit-1/localauthority.conf.d
+ keepdir /{etc,var/lib}/polkit-1/localauthority/{10-vendor.d,20-org.d,30-site.d,50-local.d,90-mandatory.d}
+}