summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-01 10:24:33 +0100
committerSam James <sam@gentoo.org>2024-09-01 10:24:33 +0100
commit876a5e69fe11b38c85839fd3906d4c5fca3f4a03 (patch)
tree265720f7d27f05c7e1ce8b39f43c3d9c64ea98bd /sys-auth
parentdev-texlive/texlive-latexextra: move dev-tex/minted to PDEPEND (diff)
downloadgentoo-876a5e69fe11b38c85839fd3906d4c5fca3f4a03.tar.gz
gentoo-876a5e69fe11b38c85839fd3906d4c5fca3f4a03.tar.bz2
gentoo-876a5e69fe11b38c85839fd3906d4c5fca3f4a03.zip
sys-auth/polkit: fix musl build
Closes: https://bugs.gentoo.org/938874 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/files/polkit-125-musl.patch34
-rw-r--r--sys-auth/polkit/polkit-125.ebuild4
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-auth/polkit/files/polkit-125-musl.patch b/sys-auth/polkit/files/polkit-125-musl.patch
new file mode 100644
index 000000000000..ee0a444c919e
--- /dev/null
+++ b/sys-auth/polkit/files/polkit-125-musl.patch
@@ -0,0 +1,34 @@
+https://github.com/polkit-org/polkit/commit/13bea3e08f924002a6a5c2f275d4bf1588fc3d02
+
+From 13bea3e08f924002a6a5c2f275d4bf1588fc3d02 Mon Sep 17 00:00:00 2001
+From: Sertonix <sertonix@posteo.net>
+Date: Sun, 11 Aug 2024 00:26:51 +0200
+Subject: [PATCH] Fix missing arguments with HAVE_PTHREAD_CONDATTR_SETCLOCK
+
+Fixes <64f5e4dda52> Add syslog-style log levels support
+--- a/src/polkitbackend/polkitbackendduktapeauthority.c
++++ b/src/polkitbackend/polkitbackendduktapeauthority.c
+@@ -767,12 +767,14 @@ runaway_killer_common(PolkitBackendJsAuthority *authority, RunawayKillerCtx *ctx
+ #ifdef HAVE_PTHREAD_CONDATTR_SETCLOCK
+ if ((pthread_err = pthread_condattr_init(&attr))) {
+ polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
++ LOG_LEVEL_ERROR,
+ "Error initializing condition variable attributes: %s",
+ strerror(pthread_err));
+ return FALSE;
+ }
+ if ((pthread_err = pthread_condattr_setclock(&attr, PK_CLOCK))) {
+ polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
++ LOG_LEVEL_ERROR,
+ "Error setting condition variable attributes: %s",
+ strerror(pthread_err));
+ goto err_clean_condattr;
+@@ -780,6 +782,7 @@ runaway_killer_common(PolkitBackendJsAuthority *authority, RunawayKillerCtx *ctx
+ /* Init again, with needed attr */
+ if ((pthread_err = pthread_cond_init(&ctx->cond, &attr))) {
+ polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
++ LOG_LEVEL_ERROR,
+ "Error initializing condition variable: %s",
+ strerror(pthread_err));
+ goto err_clean_condattr;
+
diff --git a/sys-auth/polkit/polkit-125.ebuild b/sys-auth/polkit/polkit-125.ebuild
index 53939dcb72eb..fa58387359d1 100644
--- a/sys-auth/polkit/polkit-125.ebuild
+++ b/sys-auth/polkit/polkit-125.ebuild
@@ -80,6 +80,10 @@ QA_MULTILIB_PATHS="
usr/lib/polkit-1/polkitd
"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
python_check_deps() {
python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]" &&
python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"