summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 12:50:16 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 12:50:16 +0100
commitc381d2a51249c41ce1b0322884f324db769feb66 (patch)
treea6d1716292795f01203ea7e131fb880f32176c6c /sys-block/vblade/vblade-24.ebuild
parentsys-devel/remake: fix build with gcc-10 (diff)
downloadgentoo-c381d2a51249c41ce1b0322884f324db769feb66.tar.gz
gentoo-c381d2a51249c41ce1b0322884f324db769feb66.tar.bz2
gentoo-c381d2a51249c41ce1b0322884f324db769feb66.zip
sys-block/vblade: fix build with gcc-10
Closes: https://bugs.gentoo.org/707480 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-block/vblade/vblade-24.ebuild')
-rw-r--r--sys-block/vblade/vblade-24.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/sys-block/vblade/vblade-24.ebuild b/sys-block/vblade/vblade-24.ebuild
index 418e75559d0c..e8ee9b2db33c 100644
--- a/sys-block/vblade/vblade-24.ebuild
+++ b/sys-block/vblade/vblade-24.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit toolchain-funcs
@@ -17,23 +17,22 @@ RDEPEND="sys-apps/util-linux"
S="${WORKDIR}/${PN}-${P}"
-src_prepare() {
- default
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
- sed -i -e 's,^CFLAGS.*,CFLAGS += -Wall,' \
- -e 's:-o vblade:${LDFLAGS} \0:' \
- makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC
}
src_install() {
dosbin vblade
dosbin "${FILESDIR}"/vbladed
+
doman vblade.8
dodoc HACKING NEWS README
+
newconfd "${FILESDIR}"/conf.d-vblade vblade
newinitd "${FILESDIR}"/init.d-vblade.vblade0-r2 vblade.vblade0
}