summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-06-14 09:16:34 -0500
committerBen Kohler <bkohler@gentoo.org>2024-06-14 09:16:34 -0500
commit239c87689a1bbac85b623f81a1ecb89859c4ce96 (patch)
treee69a607f5dc52a43ceac0fa96cb05f593be0be28 /sys-boot
parentsys-boot/os-prober: stabilize 1.81-r3 for amd64, x86 (diff)
downloadgentoo-239c87689a1bbac85b623f81a1ecb89859c4ce96.tar.gz
gentoo-239c87689a1bbac85b623f81a1ecb89859c4ce96.tar.bz2
gentoo-239c87689a1bbac85b623f81a1ecb89859c4ce96.zip
sys-boot/os-prober: drop 1.80, 1.81, 1.81-r1, 1.81-r2
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/os-prober/Manifest1
-rw-r--r--sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice-v2.patch57
-rw-r--r--sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice.patch46
-rw-r--r--sys-boot/os-prober/os-prober-1.80.ebuild102
-rw-r--r--sys-boot/os-prober/os-prober-1.81-r1.ebuild103
-rw-r--r--sys-boot/os-prober/os-prober-1.81-r2.ebuild103
-rw-r--r--sys-boot/os-prober/os-prober-1.81.ebuild102
7 files changed, 0 insertions, 514 deletions
diff --git a/sys-boot/os-prober/Manifest b/sys-boot/os-prober/Manifest
index 82c24eab534c..cba10225f1fb 100644
--- a/sys-boot/os-prober/Manifest
+++ b/sys-boot/os-prober/Manifest
@@ -1,3 +1,2 @@
-DIST os-prober_1.80.tar.xz 27400 BLAKE2B 56883c7d3f4c5dde2904cffc77fdf6a2c1caf230f9e84197e8d976e446815838448bb42afd18d4c9526efac9907db3d2e77c6f54889011d2d03d284a44ff4cbd SHA512 51b4fefb784d5ecf34f5148157ef233e2979c4a679a54600144be473bb6ccaf263c9121701a1ecc7523c7e3bfc439a4e3a92a5eb92431ead99cbe666b0f0e6f5
DIST os-prober_1.81.tar.xz 27448 BLAKE2B 0159870612d265c5e610e093a8839129aa9dc111a6f3abee65a6044b4c997ba65a69f70deca246bde53c1cf5314812312178e82c0893093d9f23ced3b0176f9d SHA512 ffb0e618f9e58a7a8e4a265d253bad4e168c220697216684acb38dbfa20680e552eb7c5f3d2186cd750c61a8929bf152527aa85c39318ed8b025a4ffffadde50
DIST os-prober_1.82.tar.xz 27596 BLAKE2B 2d703cf91931fbdc89f1d2ca6b2ef87368a11fb685821f4864f826b143a92c22d5544d99f0843900012f7d9ae230d9eb858de3ee99f6df5ed488c5fd604b51df SHA512 7ab1825e3d771a9fba8cff3a72dd54371e0e467090ba9780e0074a54a3a8451da5f771d7a8c9b51a5bbb03ad315d1887764335d7aaae77c2a6c4de426c667990
diff --git a/sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice-v2.patch b/sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice-v2.patch
deleted file mode 100644
index 41e661bae86f..000000000000
--- a/sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice-v2.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff --git a/common.sh b/common.sh
-index cc7a335..820caea 100644
---- a/common.sh
-+++ b/common.sh
-@@ -326,3 +326,26 @@ umount() {
- fi
- }
-
-+list_mounts() {
-+ if [ -f /proc/self/mountinfo ]; then
-+ local x dev mount devs found mountinfo_placeholders
-+ found=:
-+
-+ # mountinfo may have 10 or 11 fields depending on mount namespaces
-+ if [ $(head -n1 /proc/self/mountinfo | wc -w) == 10 ]; then
-+ mountinfo_placeholders="x x"
-+ else
-+ mountinfo_placeholders="x x x"
-+ fi
-+
-+ while read -r x x dev x mount ${mountinfo_placeholders} fs x; do
-+ if [ -L "/sys/dev/block/$dev" ]; then
-+ devs="/dev/`readlink \"/sys/dev/block/$dev\" | rev | cut -d/ -f1 | rev`"
-+ printf '%s %s %s\n' "$(mapdevfs "$devs")" "$mount" "$fs"
-+ found="return 0"
-+ fi
-+ done < /proc/self/mountinfo
-+ $found
-+ fi
-+ grep "^/dev/" /proc/mounts | parse_proc_mounts
-+}
-diff --git a/linux-boot-prober b/linux-boot-prober
-index bacf219..804d9fe 100755
---- a/linux-boot-prober
-+++ b/linux-boot-prober
-@@ -17,7 +17,7 @@ bootmnt=
- bootsv=
- bootuuid=
-
--grep "^/dev/" /proc/mounts | parse_proc_mounts >"$OS_PROBER_TMP/mounted-map" || true
-+list_mounts >"$OS_PROBER_TMP/mounted-map" || true
-
- if [ -z "$1" ]; then
- ERR=y
-diff --git a/os-prober b/os-prober
-index b76d85b..8b0c89b 100755
---- a/os-prober
-+++ b/os-prober
-@@ -128,7 +128,7 @@ done
-
- # We need to properly canonicalize partitions with mount points and partitions
- # used in RAID
--grep "^/dev/" /proc/mounts | parse_proc_mounts >"$OS_PROBER_TMP/mounted-map" || true
-+list_mounts >"$OS_PROBER_TMP/mounted-map" || true
- : >"$OS_PROBER_TMP/swaps-map"
- if [ -f /proc/swaps ]; then
- grep "^/dev/" /proc/swaps | parse_proc_swaps >"$OS_PROBER_TMP/swaps-map" || true
diff --git a/sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice.patch b/sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice.patch
deleted file mode 100644
index b06b31d0077e..000000000000
--- a/sys-boot/os-prober/files/os-prober-1.81-boot-detected-twice.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -urN o/common.sh os-prober-1.81/common.sh
---- o/common.sh 2023-01-22 13:43:23.333123217 -0800
-+++ os-prober-1.81/common.sh 2023-01-22 13:44:49.408153101 -0800
-@@ -326,3 +326,18 @@
- fi
- }
-
-+list_mounts() {
-+ if [ -f /proc/self/mountinfo ]; then
-+ local x dev mount devs found
-+ found=:
-+ while read -r x x dev x mount x x fs x; do
-+ if [ -L "/sys/dev/block/$dev" ]; then
-+ devs="/dev/`readlink \"/sys/dev/block/$dev\" | rev | cut -d/ -f1 | rev`"
-+ printf '%s %s %s\n' "$(mapdevfs "$devs")" "$mount" "$fs"
-+ found="return 0"
-+ fi
-+ done < /proc/self/mountinfo
-+ $found
-+ fi
-+ grep "^/dev/" /proc/mounts | parse_proc_mounts
-+}
-diff -urN o/linux-boot-prober os-prober-1.81/linux-boot-prober
---- o/linux-boot-prober 2023-01-22 13:43:23.334123229 -0800
-+++ os-prober-1.81/linux-boot-prober 2023-01-22 13:43:34.897260733 -0800
-@@ -17,7 +17,7 @@
- bootsv=
- bootuuid=
-
--grep "^/dev/" /proc/mounts | parse_proc_mounts >"$OS_PROBER_TMP/mounted-map" || true
-+list_mounts >"$OS_PROBER_TMP/mounted-map" || true
-
- if [ -z "$1" ]; then
- ERR=y
-diff -urN o/os-prober os-prober-1.81/os-prober
---- o/os-prober 2023-01-22 13:43:23.334123229 -0800
-+++ os-prober-1.81/os-prober 2023-01-22 13:43:34.897260733 -0800
-@@ -128,7 +128,7 @@
-
- # We need to properly canonicalize partitions with mount points and partitions
- # used in RAID
--grep "^/dev/" /proc/mounts | parse_proc_mounts >"$OS_PROBER_TMP/mounted-map" || true
-+list_mounts >"$OS_PROBER_TMP/mounted-map" || true
- : >"$OS_PROBER_TMP/swaps-map"
- if [ -f /proc/swaps ]; then
- grep "^/dev/" /proc/swaps | parse_proc_swaps >"$OS_PROBER_TMP/swaps-map" || true
diff --git a/sys-boot/os-prober/os-prober-1.80.ebuild b/sys-boot/os-prober/os-prober-1.80.ebuild
deleted file mode 100644
index 39b187859a6e..000000000000
--- a/sys-boot/os-prober/os-prober-1.80.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit readme.gentoo-r1 toolchain-funcs
-
-DESCRIPTION="Utility to detect other OSs on a set of drives"
-HOMEPAGE="https://salsa.debian.org/installer-team/os-prober"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://salsa.debian.org/installer-team/${PN}.git"
-else
- SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# grub-mount needed per bug #607518
-RDEPEND="sys-boot/grub:2[mount]"
-
-# bug 594250
-QA_MULTILIB_PATHS="usr/lib/os-prober/.*"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.79-mdraid-detection.patch
- "${FILESDIR}"/${PN}-1.79-btrfs-subvolume-detection.patch
- "${FILESDIR}"/${PN}-1.79-use-fstab-name.patch
- "${FILESDIR}"/${PN}-1.79-mounted-boot-partition-fix.patch
- "${FILESDIR}"/${PN}-1.79-fix-busy-umount-message.patch
- "${FILESDIR}"/${PN}-1.79-efi-chroot-blkid-fallback.patch
-)
-
-DOC_CONTENTS="
- If you intend for os-prober to detect versions of Windows installed on
- NTFS-formatted partitions, your system must be capable of reading the
- NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g.
-
- NOTE: Since sys-boot/grub-2.06-rc1, grub-mkconfig disables os-prober by default.
- To enable it, add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub.
-"
-
-src_prepare() {
- default
- # use default GNU rules
- rm Makefile || die 'rm Makefile failed'
-}
-
-src_compile() {
- tc-export CC
- emake newns
-}
-
-src_install() {
- dobin os-prober linux-boot-prober
-
- # Note: as no shared libraries are installed, /usr/lib is correct
- exeinto /usr/lib/os-prober
- doexe newns
-
- insinto /usr/share/os-prober
- doins common.sh
-
- keepdir /var/lib/os-prober
-
- local debarch=${ARCH%-*} dir
-
- case ${debarch} in
- amd64) debarch=x86 ;;
- ppc|ppc64) debarch=powerpc ;;
- esac
-
- for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
- exeinto /usr/lib/${dir}
- doexe ${dir}/common/*
- if [[ -d ${dir}/${debarch} ]]; then
- for exe in ${dir}/${debarch}/*; do
- [[ ! -d "${exe}" ]] && doexe "${exe}"
- done
- fi
- if [[ -d ${dir}/${debarch}/efi ]]; then
- exeinto /usr/lib/${dir}/efi
- doexe ${dir}/${debarch}/efi/*
- fi
- done
-
- if use amd64 || use x86; then
- exeinto /usr/lib/os-probes/mounted
- doexe os-probes/mounted/powerpc/20macosx
- fi
-
- einstalldocs
- dodoc debian/changelog
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/sys-boot/os-prober/os-prober-1.81-r1.ebuild b/sys-boot/os-prober/os-prober-1.81-r1.ebuild
deleted file mode 100644
index 924b7251237a..000000000000
--- a/sys-boot/os-prober/os-prober-1.81-r1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit readme.gentoo-r1 toolchain-funcs
-
-DESCRIPTION="Utility to detect other OSs on a set of drives"
-HOMEPAGE="https://salsa.debian.org/installer-team/os-prober"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://salsa.debian.org/installer-team/${PN}.git"
-else
- SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# grub-mount needed per bug #607518
-RDEPEND="sys-boot/grub:2[mount]"
-
-# bug 594250
-QA_MULTILIB_PATHS="usr/lib/os-prober/.*"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.79-mdraid-detection.patch
- "${FILESDIR}"/${PN}-1.79-btrfs-subvolume-detection.patch
- "${FILESDIR}"/${PN}-1.79-use-fstab-name.patch
- "${FILESDIR}"/${PN}-1.79-mounted-boot-partition-fix.patch
- "${FILESDIR}"/${PN}-1.79-fix-busy-umount-message.patch
- "${FILESDIR}"/${PN}-1.79-efi-chroot-blkid-fallback.patch
- "${FILESDIR}"/${PN}-1.81-boot-detected-twice.patch
-)
-
-DOC_CONTENTS="
- If you intend for os-prober to detect versions of Windows installed on
- NTFS-formatted partitions, your system must be capable of reading the
- NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g.
-
- NOTE: Since sys-boot/grub-2.06-rc1, grub-mkconfig disables os-prober by default.
- To enable it, add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub.
-"
-
-src_prepare() {
- default
- # use default GNU rules
- rm Makefile || die 'rm Makefile failed'
-}
-
-src_compile() {
- tc-export CC
- emake newns
-}
-
-src_install() {
- dobin os-prober linux-boot-prober
-
- # Note: as no shared libraries are installed, /usr/lib is correct
- exeinto /usr/lib/os-prober
- doexe newns
-
- insinto /usr/share/os-prober
- doins common.sh
-
- keepdir /var/lib/os-prober
-
- local debarch=${ARCH%-*} dir
-
- case ${debarch} in
- amd64) debarch=x86 ;;
- ppc|ppc64) debarch=powerpc ;;
- esac
-
- for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
- exeinto /usr/lib/${dir}
- doexe ${dir}/common/*
- if [[ -d ${dir}/${debarch} ]]; then
- for exe in ${dir}/${debarch}/*; do
- [[ ! -d "${exe}" ]] && doexe "${exe}"
- done
- fi
- if [[ -d ${dir}/${debarch}/efi ]]; then
- exeinto /usr/lib/${dir}/efi
- doexe ${dir}/${debarch}/efi/*
- fi
- done
-
- if use amd64 || use x86; then
- exeinto /usr/lib/os-probes/mounted
- doexe os-probes/mounted/powerpc/20macosx
- fi
-
- einstalldocs
- dodoc debian/changelog
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/sys-boot/os-prober/os-prober-1.81-r2.ebuild b/sys-boot/os-prober/os-prober-1.81-r2.ebuild
deleted file mode 100644
index 59252bb84f92..000000000000
--- a/sys-boot/os-prober/os-prober-1.81-r2.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit readme.gentoo-r1 toolchain-funcs
-
-DESCRIPTION="Utility to detect other OSs on a set of drives"
-HOMEPAGE="https://salsa.debian.org/installer-team/os-prober"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://salsa.debian.org/installer-team/${PN}.git"
-else
- SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# grub-mount needed per bug #607518
-RDEPEND="sys-boot/grub:2[mount]"
-
-# bug 594250
-QA_MULTILIB_PATHS="usr/lib/os-prober/.*"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.79-mdraid-detection.patch
- "${FILESDIR}"/${PN}-1.79-btrfs-subvolume-detection.patch
- "${FILESDIR}"/${PN}-1.79-use-fstab-name.patch
- "${FILESDIR}"/${PN}-1.79-mounted-boot-partition-fix.patch
- "${FILESDIR}"/${PN}-1.79-fix-busy-umount-message.patch
- "${FILESDIR}"/${PN}-1.79-efi-chroot-blkid-fallback.patch
- "${FILESDIR}"/${PN}-1.81-boot-detected-twice-v2.patch
-)
-
-DOC_CONTENTS="
- If you intend for os-prober to detect versions of Windows installed on
- NTFS-formatted partitions, your system must be capable of reading the
- NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g.
-
- NOTE: Since sys-boot/grub-2.06-rc1, grub-mkconfig disables os-prober by default.
- To enable it, add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub.
-"
-
-src_prepare() {
- default
- # use default GNU rules
- rm Makefile || die 'rm Makefile failed'
-}
-
-src_compile() {
- tc-export CC
- emake newns
-}
-
-src_install() {
- dobin os-prober linux-boot-prober
-
- # Note: as no shared libraries are installed, /usr/lib is correct
- exeinto /usr/lib/os-prober
- doexe newns
-
- insinto /usr/share/os-prober
- doins common.sh
-
- keepdir /var/lib/os-prober
-
- local debarch=${ARCH%-*} dir
-
- case ${debarch} in
- amd64) debarch=x86 ;;
- ppc|ppc64) debarch=powerpc ;;
- esac
-
- for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
- exeinto /usr/lib/${dir}
- doexe ${dir}/common/*
- if [[ -d ${dir}/${debarch} ]]; then
- for exe in ${dir}/${debarch}/*; do
- [[ ! -d "${exe}" ]] && doexe "${exe}"
- done
- fi
- if [[ -d ${dir}/${debarch}/efi ]]; then
- exeinto /usr/lib/${dir}/efi
- doexe ${dir}/${debarch}/efi/*
- fi
- done
-
- if use amd64 || use x86; then
- exeinto /usr/lib/os-probes/mounted
- doexe os-probes/mounted/powerpc/20macosx
- fi
-
- einstalldocs
- dodoc debian/changelog
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/sys-boot/os-prober/os-prober-1.81.ebuild b/sys-boot/os-prober/os-prober-1.81.ebuild
deleted file mode 100644
index 39b187859a6e..000000000000
--- a/sys-boot/os-prober/os-prober-1.81.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit readme.gentoo-r1 toolchain-funcs
-
-DESCRIPTION="Utility to detect other OSs on a set of drives"
-HOMEPAGE="https://salsa.debian.org/installer-team/os-prober"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://salsa.debian.org/installer-team/${PN}.git"
-else
- SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# grub-mount needed per bug #607518
-RDEPEND="sys-boot/grub:2[mount]"
-
-# bug 594250
-QA_MULTILIB_PATHS="usr/lib/os-prober/.*"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.79-mdraid-detection.patch
- "${FILESDIR}"/${PN}-1.79-btrfs-subvolume-detection.patch
- "${FILESDIR}"/${PN}-1.79-use-fstab-name.patch
- "${FILESDIR}"/${PN}-1.79-mounted-boot-partition-fix.patch
- "${FILESDIR}"/${PN}-1.79-fix-busy-umount-message.patch
- "${FILESDIR}"/${PN}-1.79-efi-chroot-blkid-fallback.patch
-)
-
-DOC_CONTENTS="
- If you intend for os-prober to detect versions of Windows installed on
- NTFS-formatted partitions, your system must be capable of reading the
- NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g.
-
- NOTE: Since sys-boot/grub-2.06-rc1, grub-mkconfig disables os-prober by default.
- To enable it, add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub.
-"
-
-src_prepare() {
- default
- # use default GNU rules
- rm Makefile || die 'rm Makefile failed'
-}
-
-src_compile() {
- tc-export CC
- emake newns
-}
-
-src_install() {
- dobin os-prober linux-boot-prober
-
- # Note: as no shared libraries are installed, /usr/lib is correct
- exeinto /usr/lib/os-prober
- doexe newns
-
- insinto /usr/share/os-prober
- doins common.sh
-
- keepdir /var/lib/os-prober
-
- local debarch=${ARCH%-*} dir
-
- case ${debarch} in
- amd64) debarch=x86 ;;
- ppc|ppc64) debarch=powerpc ;;
- esac
-
- for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
- exeinto /usr/lib/${dir}
- doexe ${dir}/common/*
- if [[ -d ${dir}/${debarch} ]]; then
- for exe in ${dir}/${debarch}/*; do
- [[ ! -d "${exe}" ]] && doexe "${exe}"
- done
- fi
- if [[ -d ${dir}/${debarch}/efi ]]; then
- exeinto /usr/lib/${dir}/efi
- doexe ${dir}/${debarch}/efi/*
- fi
- done
-
- if use amd64 || use x86; then
- exeinto /usr/lib/os-probes/mounted
- doexe os-probes/mounted/powerpc/20macosx
- fi
-
- einstalldocs
- dodoc debian/changelog
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}