summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-09-07 16:37:44 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-09-07 16:37:44 -0700
commite282ab19abdaa03f1405a11e363d281ea5a070aa (patch)
treeb58eefa8ef0a43dc5d4bfe3929eb3ec139de3942 /sys-cluster/ceph/ceph-10.2.9-r3.ebuild
parentsys-cluster/ceph: Revision bump to 12.2.0-r1, fix references to temp python link (diff)
downloadgentoo-e282ab19abdaa03f1405a11e363d281ea5a070aa.tar.gz
gentoo-e282ab19abdaa03f1405a11e363d281ea5a070aa.tar.bz2
gentoo-e282ab19abdaa03f1405a11e363d281ea5a070aa.zip
sys-cluster/ceph: Fix 10.2.9-r3 to respect CFLAGS
Also don't call lsb_release if it is not installed. Filter debugging CFLAGS with gcc-7.2.0 as it causes the compiler to crash. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-cluster/ceph/ceph-10.2.9-r3.ebuild')
-rw-r--r--sys-cluster/ceph/ceph-10.2.9-r3.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-cluster/ceph/ceph-10.2.9-r3.ebuild b/sys-cluster/ceph/ceph-10.2.9-r3.ebuild
index edd9ac4bbd65..73d8983868db 100644
--- a/sys-cluster/ceph/ceph-10.2.9-r3.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.9-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
inherit check-reqs autotools eutils python-r1 udev user \
- readme.gentoo-r1 systemd versionator flag-o-matic
+ readme.gentoo-r1 systemd versionator flag-o-matic toolchain-funcs
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -114,6 +114,8 @@ PATCHES=(
"${FILESDIR}/${PN}-10.2.5-Make-RBD-Python-bindings-compatible-with-Python-3.patch"
"${FILESDIR}/${PN}-10.2.5-Make-CephFS-bindings-and-tests-compatible-with-Python-3.patch"
"${FILESDIR}/${PN}-10.2.7-fix-compilation-with-zstd.patch"
+ "${FILESDIR}/${PN}-10.2.9-cflags.patch"
+ "${FILESDIR}/${PN}-10.2.9-dont-run-lsb_release.patch"
# pull in some bugfixes from upstream
"${FILESDIR}/${PN}-10.2.9-libradosstriper_fix_format_injection_vulnerability.patch"
"${FILESDIR}/${PN}-10.2.9-rbd-nbd_relax_size_check_for_newer_kernel_versions.patch"
@@ -122,7 +124,6 @@ PATCHES=(
"${FILESDIR}/${PN}-10.2.9-osd-scrub_to_specifies_clone_ver_but_transaction_include.patch"
"${FILESDIR}/${PN}-10.2.9-rbd-do_not_attempt_to_load_key_if_auth_is_disabled.patch"
"${FILESDIR}/${PN}-10.2.9-unlock_sdata_op_ordering_lock_with_sdata_lock.patch"
-
)
check-reqs_export_vars() {
@@ -197,6 +198,11 @@ src_prepare() {
#rm -rf "${UNBUNDLE_LIBS[@]}"
append-flags -fPIC
+
+ if tc-is-gcc && [[ $(gcc-fullversion) == "7.2.0" ]] && is-flag "-g*"; then
+ ewarn "Filtering out -g* flags since gcc-7.2 tends to ICE with them and ceph"
+ filter-flags "-g*"
+ fi
eautoreconf
}