summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-13 05:49:21 +0000
committerSam James <sam@gentoo.org>2022-03-13 05:49:53 +0000
commitf2884cffd6f8b05d6324e9f63ed1c672b2b34be1 (patch)
tree4e139b39853282b3d8fadec4a30e81893e24a9ab /sys-cluster/crmsh
parentmedia-libs/libbluray: drop static-libs in 1.3.1 (diff)
downloadgentoo-f2884cffd6f8b05d6324e9f63ed1c672b2b34be1.tar.gz
gentoo-f2884cffd6f8b05d6324e9f63ed1c672b2b34be1.tar.bz2
gentoo-f2884cffd6f8b05d6324e9f63ed1c672b2b34be1.zip
sys-cluster/crmsh: [QA] use eautoreconf
- AUTOTOOLS_AUTORECONF was for autotools-utils.eclass, not autotools.eclass, but autotools-utils.eclass (which is gone) wasn't being inherited anyway. - Use eautoreconf instead of autogen.sh (handles everything we need, plus inheriting autotools.eclass guarantees correct dependencies). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/crmsh')
-rw-r--r--sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild b/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild
new file mode 100644
index 000000000000..ffab4f2a9c1d
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit autotools python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/parallax[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+}