summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 16:17:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 16:53:25 +0200
commita27abbaa95b9b5f585223a2680c560f093f389f4 (patch)
tree17a3814a95dd7154c99f2bfaefde4e7956c4f9d7 /sys-cluster/hpx
parentsys-cluster/hpx: 1.2.1 version bump (diff)
downloadgentoo-a27abbaa95b9b5f585223a2680c560f093f389f4.tar.gz
gentoo-a27abbaa95b9b5f585223a2680c560f093f389f4.tar.bz2
gentoo-a27abbaa95b9b5f585223a2680c560f093f389f4.zip
sys-cluster/hpx: EAPI-7 bump, simpler REQUIRED_USE, use https
Drop unused multilib.eclass Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild37
1 files changed, 17 insertions, 20 deletions
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
index 3fb751c6c5ad..e4605b1b99ce 100644
--- a/sys-cluster/hpx/hpx-1.2.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.2.1.ebuild
@@ -1,48 +1,45 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-CMAKE_MAKEFILE_GENERATOR="ninja"
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-if [ ${PV} == 9999 ] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
else
- SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
+ SRC_URI="https://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
fi
-
-inherit cmake-utils fortran-2 multilib python-any-r1
+inherit cmake-utils fortran-2 python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
-HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+REQUIRED_USE="?? ( jemalloc perftools tbb )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( >=dev-libs/boost-1.56.0-r1[tools] )
+"
RDEPEND="
- tbb? ( dev-cpp/tbb )
- >=dev-libs/boost-1.49
- papi? ( dev-libs/papi )
- perftools? ( >=dev-util/google-perftools-1.7.1 )
+ >=dev-libs/boost-1.49:=
>=sys-apps/hwloc-1.8
>=sys-libs/libunwind-1
sys-libs/zlib
+ papi? ( dev-libs/papi )
+ perftools? ( >=dev-util/google-perftools-1.7.1 )
+ tbb? ( dev-cpp/tbb )
"
DEPEND="${RDEPEND}
- virtual/pkgconfig
test? ( ${PYTHON_DEPS} )
- doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
"
-REQUIRED_USE="
- jemalloc? ( !perftools !tbb )
- perftools? ( !jemalloc !tbb )
- tbb? ( !jemalloc !perftools )
- "
pkg_setup() {
use test && python-any-r1_pkg_setup
@@ -62,8 +59,8 @@ src_configure() {
-DHPX_PAPI=$(usex papi)
)
- use perftools && mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
use jemalloc && mycmakeargs+=( -DHPX_MALLOC=jemalloc )
+ use perftools && mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
use tbb && mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
cmake-utils_src_configure
@@ -76,7 +73,7 @@ src_test() {
src_install() {
cmake-utils_src_install
- mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin"
+ mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples