summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2024-06-09 19:21:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-07-13 11:11:50 +0300
commitb3ff0a4b0cd54a6b1c51c6ca293be33d11e0d263 (patch)
tree5593c71d5702b1d84cc89064d0e044380d4bddee /sys-cluster/hpx
parentdev-ml/ppx_js_style: add 0.17.0 (diff)
downloadgentoo-b3ff0a4b0cd54a6b1c51c6ca293be33d11e0d263.tar.gz
gentoo-b3ff0a4b0cd54a6b1c51c6ca293be33d11e0d263.tar.bz2
gentoo-b3ff0a4b0cd54a6b1c51c6ca293be33d11e0d263.zip
sys-cluster/hpx: add 1.10.0
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/files/hpx-1.10.0-python.patch30
-rw-r--r--sys-cluster/hpx/hpx-1.10.0.ebuild105
3 files changed, 136 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 5899fb6e1134..c034dc54e809 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1 +1,2 @@
+DIST hpx-1.10.0.tar.gz 6146815 BLAKE2B eeab350944e5a7e68a0bbf2a7bac22c6d739359113ed75d5ed2ff601887c9466c6f92b80823be140e02e1a47480323b69a5f193f13b415f505ccae02792f6e1c SHA512 e1cc9fa72cba4e66b5d6eff2487e93d5d553c32e6eebcfe9131bf69c5b595ab72295ff0986c81d5dc6a7caa8303d6709df91333f64efe59ee256d99a8c289dc5
DIST hpx-1.9.1.tar.gz 5662661 BLAKE2B 81631333b8899a7271e8c6edf587d0a3afadde28f2605ac4f8ff6ddc3fa5afb5ad8d05818ae6d0bfa8fb7241d3aebfe5f838b85b77f54327010308b22b4900b7 SHA512 a7972beada950cf6ef3b61f20496a08b220e4f48c28c11d57c20683906ca5124a9f36ac2552318883a5ab1db6efdbf63d1141b6e0c484c560a8c1311ae2d7090
diff --git a/sys-cluster/hpx/files/hpx-1.10.0-python.patch b/sys-cluster/hpx/files/hpx-1.10.0-python.patch
new file mode 100644
index 000000000000..573529e76588
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-1.10.0-python.patch
@@ -0,0 +1,30 @@
+From 3d8d3acf0daad9cec8b092d67f7187265f7704e3 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Tue, 17 Mar 2020 16:20:35 +0100
+Subject: [PATCH 1/4] cmake: python: Use standard python interpreter
+
+These scripts are needed during build and run time. So, use a python interpreter
+which works for both cases.
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ cmake/templates/hpxcxx.in | 2 +-
+ cmake/templates/hpxrun.py.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/cmake/templates/hpxcxx.in
++++ b/cmake/templates/hpxcxx.in
+@@ -1,4 +1,4 @@
+-#! @Python_EXECUTABLE@
++#! /usr/bin/env python
+ #
+ # Copyright (c) 2014 Steven R. Brandt
+ #
+--- a/cmake/templates/hpxrun.py.in
++++ b/cmake/templates/hpxrun.py.in
+@@ -1,4 +1,4 @@
+-#! @Python_EXECUTABLE@
++#! /usr/bin/env python
+ #
+ # Copyright (c) 2014 Thomas Heller
+ #
diff --git a/sys-cluster/hpx/hpx-1.10.0.ebuild b/sys-cluster/hpx/hpx-1.10.0.ebuild
new file mode 100644
index 000000000000..0c9138e2ed8a
--- /dev/null
+++ b/sys-cluster/hpx/hpx-1.10.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+else
+ SRC_URI="https://github.com/STEllAR-GROUP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit check-reqs cmake multiprocessing python-single-r1
+
+DESCRIPTION="C++ runtime system for parallel and distributed applications"
+HOMEPAGE="https://hpx.stellar-group.org/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="examples jemalloc mpi papi +perftools tbb zlib"
+# tests fail to compile
+RESTRICT="test"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ?? ( jemalloc perftools tbb )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-cpp/asio-1.12.0
+ dev-libs/boost:=
+ sys-apps/hwloc:=
+ jemalloc? ( dev-libs/jemalloc:= )
+ mpi? ( virtual/mpi )
+ papi? ( dev-libs/papi )
+ perftools? ( dev-util/google-perftools:= )
+ tbb? ( dev-cpp/tbb:= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python.patch"
+)
+
+hpx_memory_requirement() {
+ # HPX needs enough main memory for compiling
+ # rule of thumb: 1G per job
+ if [[ -z ${MAKEOPTS} ]] ; then
+ echo "2G"
+ else
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+ echo "${jobs}G"
+ fi
+}
+
+pkg_pretend() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+}
+
+pkg_setup() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHPX_WITH_EXAMPLES=OFF
+ -DHPX_WITH_DOCUMENTATION=OFF
+ -DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
+ -DHPX_WITH_PAPI=$(usex papi)
+ -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
+ -DHPX_WITH_COMPRESSION_ZLIB=$(usex zlib)
+ -DHPX_WITH_TESTS=OFF
+ )
+ if use jemalloc; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
+ elif use perftools; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
+ elif use tbb; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
+ else
+ mycmakeargs+=( -DHPX_WITH_MALLOC=system )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+ use examples && dodoc -r examples/
+ python_fix_shebang "${ED}"
+}