summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-10 01:13:15 -0400
committerSam James <sam@gentoo.org>2024-06-14 07:44:42 +0100
commit837a217ce9a794d4acdb622ee49bdf8624811d75 (patch)
treefefb1e42321b0999c2eb7842ccf09b8f416cd3eb /sys-cluster/pmix
parentsys-cluster/openmpi: prevent parallel installation with pmix (diff)
downloadgentoo-837a217ce9a794d4acdb622ee49bdf8624811d75.tar.gz
gentoo-837a217ce9a794d4acdb622ee49bdf8624811d75.tar.bz2
gentoo-837a217ce9a794d4acdb622ee49bdf8624811d75.zip
sys-cluster/pmix: add 5.0.2
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/pmix')
-rw-r--r--sys-cluster/pmix/Manifest1
-rw-r--r--sys-cluster/pmix/pmix-5.0.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-cluster/pmix/Manifest b/sys-cluster/pmix/Manifest
index 720f2551e520..caa701f7530e 100644
--- a/sys-cluster/pmix/Manifest
+++ b/sys-cluster/pmix/Manifest
@@ -1,2 +1,3 @@
DIST pmix-4.2.2.tar.bz2 1639600 BLAKE2B b5109900e52750656200e7bdbdc39d870a01f5afc1fb622663dfb2c9647b1735c23ece906064b34923977c522fb5a89afc03d81b7d115b26337934ab5bfe7ce3 SHA512 b7cb1e2079d517b32fc5d99012a7c4b161c1509b3ac1e0ba7e4697f2fe0917455927d06c86ecab5f2fa6073e1f058e86260d2115b6f8cc968a43a5675439f28d
DIST pmix-4.2.8.tar.bz2 4800886 BLAKE2B 49c6c74f2a3d4826ade004e2ca69f8adafb26232b8fe92f5e620e11f93bde6a84a3611e737818564a3a5fd6fb75a4819250fa038e55aab46cf0a29c3f04e9f7e SHA512 2bc78cda82af24a9d7db204684e1778e0db183acc425095a91d46e4253209cec06542d497d5502c502b946b0ed1517f3b34f532d1107ccac1a09f2f267f14089
+DIST pmix-5.0.2.tar.bz2 4875774 BLAKE2B b15c3d4829e5b763ad9ce0f7a8e78b1eeedea829524b55b21801a397329576b66b8807e41cb0735e5a02f2f3b93d2b9ed14cf237b582e1462178cc96200350af SHA512 f6c35a551dec7eeda887087a731ef447caa7754aeab42e6bf7f054f7ec5a376863b4836b8c4cc04a3e3630f93939dd9ba08dd9823172dfbcf2d68d9243cbcbdc
diff --git a/sys-cluster/pmix/pmix-5.0.2.ebuild b/sys-cluster/pmix/pmix-5.0.2.ebuild
new file mode 100644
index 000000000000..ce44f08ba0c0
--- /dev/null
+++ b/sys-cluster/pmix/pmix-5.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="The Process Management Interface (PMI) Exascale"
+HOMEPAGE="https://openpmix.github.io/"
+SRC_URI="https://github.com/openpmix/openpmix/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+# No support for 32-bit systems as of 4.2.8 (https://github.com/open-mpi/ompi/issues/11248)
+KEYWORDS="~amd64 -x86 ~amd64-linux"
+IUSE="debug +munge pmi"
+
+RDEPEND="
+ dev-libs/libevent:=
+ sys-apps/hwloc:=
+ sys-cluster/ucx
+ sys-libs/zlib:=
+ munge? ( sys-auth/munge )
+ pmi? ( !sys-cluster/slurm )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://github.com/openpmix/openpmix/issues/3350
+ filter-lto
+
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with munge)
+}
+
+src_install() {
+ default
+
+ # bug #884765
+ mv "${ED}"/usr/bin/pquery "${ED}"/usr/bin/pmix-pquery || die
+}