summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-06-23 18:48:49 +0100
committerJustin Lecher <jlec@gentoo.org>2018-06-23 19:36:56 +0100
commitb55ebbeeeff8e43fe6be587c990d3c662c603128 (patch)
treec737cae82bd4314a87862f72596f4f40076b995d /sys-cluster/ucx/ucx-1.2.2-r1.ebuild
parentlxde-base/lxtask: amd64 stable wrt bug #654908 (diff)
downloadgentoo-b55ebbeeeff8e43fe6be587c990d3c662c603128.tar.gz
gentoo-b55ebbeeeff8e43fe6be587c990d3c662c603128.tar.bz2
gentoo-b55ebbeeeff8e43fe6be587c990d3c662c603128.zip
sys-cluster/ucx: Fix numa support
Closes: https://bugs.gentoo.org/654432 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-cluster/ucx/ucx-1.2.2-r1.ebuild')
-rw-r--r--sys-cluster/ucx/ucx-1.2.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/ucx/ucx-1.2.2-r1.ebuild b/sys-cluster/ucx/ucx-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..c3bf36aa7359
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.2.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ numa? ( sys-process/numactl )
+"
+
+src_prepare() {
+ default
+ sed \
+ -e '/BASE_CFLAGS=/s:=".*":=:g' \
+ -i config/m4/compiler.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}