summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2018-03-16 22:27:04 -0400
committerMichał Górny <mgorny@gentoo.org>2018-03-18 09:25:23 +0100
commitf36bead374f8228e6ae648c92fd3dfdf6abbd70b (patch)
tree7a7caa5909de5a91afeba1e54ffc36ddf6aec829 /sys-cluster
parentsys-cluster/teleport: remove v2.4.0 (diff)
downloadgentoo-f36bead374f8228e6ae648c92fd3dfdf6abbd70b.tar.gz
gentoo-f36bead374f8228e6ae648c92fd3dfdf6abbd70b.tar.bz2
gentoo-f36bead374f8228e6ae648c92fd3dfdf6abbd70b.zip
sys-cluster/teleport: add v2.4.5
starting with teleport-v2.4.4, go-1.9.2 was the standard for building releases: https://github.com/gravitational/teleport/releases/tag/v2.4.4
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-2.4.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index 0a87ec92ebb0..e28f189fd839 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -1 +1,2 @@
DIST teleport-2.4.2.tar.gz 9975909 BLAKE2B 68916e1d15f49448e918b39b2a760f90eca292b07f61e51cfe125eb99c6b36d95a528cfec40b62cd61893ce81edbf5f26066eb59063214369402e2a62d07bd5e SHA512 f9c2f923e05c8fa0b82708955c944e1bd35da2e6bf8b673832e76c91b918a4bc6d6666797faf0f7572cfaa7341991ef8937cd9b374cdc273271aff45f96b2960
+DIST teleport-2.4.5.tar.gz 9975753 BLAKE2B cdb6e577cd565cf6760d73c92cac674571e9b1257d23b280bd96428cca4e7c593738a925d3632a80fed3e0868c5f3aac79800db19bbf2a2b92d495600bf014cc SHA512 15e7e3c52c058625eb525c7c9cda00186eba037edbed89d21fb090b87c05570a1636f328260d4c7445253b0f5b81f321ce0da7d2b7fc316a0a9938ed22cc6c9c
diff --git a/sys-cluster/teleport/teleport-2.4.5.ebuild b/sys-cluster/teleport/teleport-2.4.5.ebuild
new file mode 100644
index 000000000000..7592c615c45a
--- /dev/null
+++ b/sys-cluster/teleport/teleport-2.4.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils golang-build systemd user
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+IUSE=""
+LICENSE="Apache-2.0"
+RESTRICT="test strip"
+SLOT="0"
+
+DEPEND="
+ app-arch/zip
+ >=dev-lang/go-1.9.2"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ sed -i -e 's/-j 4/-j 1/g' src/${EGO_PN%/*}/Makefile
+}
+
+src_compile() {
+ GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
+}
+
+src_install() {
+ keepdir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}