summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-07-28 15:04:32 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-07-28 15:05:08 +0200
commit4b7cc82cc54c61b3c2da17ff584c301cf2fecc63 (patch)
treefafae292e543143e5777f82bd9aefcf1a89df724 /sys-devel/binutils-config
parentmail-filter/opendkim: EAPI=8 bump and another implicit decl patch (diff)
downloadgentoo-4b7cc82cc54c61b3c2da17ff584c301cf2fecc63.tar.gz
gentoo-4b7cc82cc54c61b3c2da17ff584c301cf2fecc63.tar.bz2
gentoo-4b7cc82cc54c61b3c2da17ff584c301cf2fecc63.zip
sys-devel/binutils-config: add 5.5.1
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-devel/binutils-config')
-rw-r--r--sys-devel/binutils-config/Manifest1
-rw-r--r--sys-devel/binutils-config/binutils-config-5.5.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-devel/binutils-config/Manifest b/sys-devel/binutils-config/Manifest
index de1dcd4ed1a2..b3300cdccd34 100644
--- a/sys-devel/binutils-config/Manifest
+++ b/sys-devel/binutils-config/Manifest
@@ -1 +1,2 @@
+DIST binutils-config-5.5.1.tar.xz 7548 BLAKE2B 37699e93c154a527a274763185b9678d6576ecebcfa5c5322c9f17322db2373743bff93c8c276152905d91d8e31e64c331d9ff8c09b1e223863970b4763c8fc4 SHA512 350c837e454e57ddf2b29d9a6e83e23f8b9981accc2fe337e29979d2714ecd5136024b6d57b895d531b035d198f42e164c86d6e9e0d6f5e8793fb6b0128c6994
DIST binutils-config-5.5.tar.xz 7344 BLAKE2B decef43013ca2f7c6d36c12d08d55f499d866b6b1b55ed58f8b2df3761077b5e2c4d09d1f2c40762d42c2d3b9827575833a502b79180ef13b845f1a39a5f2feb SHA512 6f6e21799b47e38cd61621e4ec018dc0db4811f363c0817025c3e3be651d3790b30a0cab233f35fe40b1d57c88daa246037f24a7488187f4e47cca589d87d45b
diff --git a/sys-devel/binutils-config/binutils-config-5.5.1.ebuild b/sys-devel/binutils-config/binutils-config-5.5.1.ebuild
new file mode 100644
index 000000000000..5d0c152438f5
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-5.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/binutils-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
+ # KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Toolchain"
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+IUSE="+native-symlinks"
+
+# We also RDEPEND on sys-apps/findutils which is in base @system
+RDEPEND="sys-apps/gentoo-functions"
+
+src_compile() {
+ emake PV="${PV}" USE_NATIVE_LINKS="$(usex native-symlinks)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PV="${PV}" install
+}
+
+pkg_postinst() {
+ # Re-register all targets. USE flags or new versions can change
+ # installed symlinks.
+ local x
+ for x in $(binutils-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ binutils-config ${x}
+ done
+}