summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-02-12 23:31:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-12 23:31:18 +0000
commit2daa70b566d006aa2cfba6e20842b7287766f5e5 (patch)
tree91155cd76be1a22d9cdd099481e5b2b9d406b1a9 /sys-devel/binutils/binutils-9999.ebuild
parentsys-devel/binutils: add USE=default-gold, bug #496760 (diff)
downloadgentoo-2daa70b566d006aa2cfba6e20842b7287766f5e5.tar.gz
gentoo-2daa70b566d006aa2cfba6e20842b7287766f5e5.tar.bz2
gentoo-2daa70b566d006aa2cfba6e20842b7287766f5e5.zip
sys-devel/binutils: split USE="cxx" into USE="gold plugins"
Reported-by: Dirkjan Ochtman Bug: https://bugs.gentoo.org/663776 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/binutils/binutils-9999.ebuild')
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index 4e2bb0f4ec75..7debbc5c53e4 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -8,7 +8,8 @@ inherit eutils libtool flag-o-matic gnuconfig multilib versionator
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="https://sourceware.org/binutils/"
LICENSE="GPL-3+"
-IUSE="+cxx doc multitarget +nls static-libs test"
+IUSE="default-gold doc +gold multitarget +nls +plugins static-libs test"
+REQUIRED_USE="default-gold? ( gold )"
# Variables that can be set here:
# PATCH_VER - the patchset version
@@ -174,10 +175,12 @@ src_configure() {
cd "${MY_BUILDDIR}"
local myconf=()
+ if use plugins ; then
+ myconf+=( --enable-plugins )
+ fi
# enable gold (installed as ld.gold) and ld's plugin architecture
- if use cxx ; then
+ if use gold ; then
myconf+=( --enable-gold )
- myconf+=( --enable-plugins )
if use default-gold; then
myconf+=( --enable-gold=default )
fi