summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-01 19:11:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-01 22:19:52 +0200
commitab69b7cad8f5f20b2c0ddea1b00d1ef9b06bc1d6 (patch)
tree4be3a7d3c9d00ae1b6c9461e3dd4bfecb33c5249 /sys-devel/clang/clang-20.0.0.9999.ebuild
parentsys-devel/llvm: Update components for 20.x (diff)
downloadgentoo-ab69b7cad8f5f20b2c0ddea1b00d1ef9b06bc1d6.tar.gz
gentoo-ab69b7cad8f5f20b2c0ddea1b00d1ef9b06bc1d6.tar.bz2
gentoo-ab69b7cad8f5f20b2c0ddea1b00d1ef9b06bc1d6.zip
sys-devel/clang: Make component mismatches fatal
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang/clang-20.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang/clang-20.0.0.9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-devel/clang/clang-20.0.0.9999.ebuild b/sys-devel/clang/clang-20.0.0.9999.ebuild
index e97008f8ad7a..857f7b1ed5a2 100644
--- a/sys-devel/clang/clang-20.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-20.0.0.9999.ebuild
@@ -137,9 +137,10 @@ check_distribution_components() {
done
if [[ ${#add[@]} -gt 0 || ${#remove[@]} -gt 0 ]]; then
- eqawarn "get_distribution_components() is outdated!"
- eqawarn " Add: ${add[*]}"
- eqawarn "Remove: ${remove[*]}"
+ eerror "get_distribution_components() is outdated!"
+ eerror " Add: ${add[*]}"
+ eerror "Remove: ${remove[*]}"
+ die "Update get_distribution_components()!"
fi
cd - >/dev/null || die
fi