summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-23 19:21:32 +0100
committerSam James <sam@gentoo.org>2023-04-23 19:21:56 +0100
commit5fb7707f5d6f435d24639685a127f04b1c304787 (patch)
treee2d2873c9c72229dc0638928d9897b05bbbaaa3d /sys-devel/crossdev
parentwww-apps/xpra-html5: Drop old 5.0 (diff)
downloadgentoo-5fb7707f5d6f435d24639685a127f04b1c304787.tar.gz
gentoo-5fb7707f5d6f435d24639685a127f04b1c304787.tar.bz2
gentoo-5fb7707f5d6f435d24639685a127f04b1c304787.zip
sys-devel/crossdev: add 20230321
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20230321.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 061db1b7d081..997f0443dd06 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1 +1,2 @@
DIST crossdev-20230209.tar.xz 29608 BLAKE2B 591e854f798c4abf90950a5ab229b14740cd43a77f83f85827487d2339a040eaf107305ef993a24783281f2f655eb377c60d043c071788cc2e798c746d9498b3 SHA512 41e482e6f5614d3ea3bcc3115f9aa86ba6c9302fef67af5b0c0058deba106c60f0b13e8881b7246180ce6d3bfaf77516e45e4f444317dc4eaec074850b79f4b4
+DIST crossdev-20230321.tar.xz 29620 BLAKE2B a5070ccf8b5e4fd9a6f63f6a903126a6eb199d7dfdcfbe93f0917a66894c4eef2df5749c0fddaf564fe013b40a14d88b2686700034642fb1d876b51731964a49 SHA512 c300b506bb7ed4aa5d43601b37c8298367f6e5307a97b19a23f39e9559e54d2bfdb6e2b7a5fde4d5ff0b4a9b02c1b6f05be92d1857352db6cde9a469c9159e5f
diff --git a/sys-devel/crossdev/crossdev-20230321.ebuild b/sys-devel/crossdev/crossdev-20230321.ebuild
new file mode 100644
index 000000000000..d15bf1ee5010
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20230321.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/crossdev.git
+ https://github.com/gentoo/crossdev
+ "
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+ sys-apps/config-site
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+
+ dodir /usr/share/config.site.d
+ mv "${ED}"/usr/share/config.site{,.d/80crossdev.conf} || die
+}