summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-28 16:46:09 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-28 18:19:25 +0200
commit2ab1d293f6a880b9111284c26e7e71458604fa30 (patch)
tree5453c27a1585e8f1006132535ab462baf3b5a2de /sys-devel/llvm/llvm-3.8.1-r2.ebuild
parentdev-util/cmake: Backport find_library() lib32 fix, #338492 (diff)
downloadgentoo-2ab1d293f6a880b9111284c26e7e71458604fa30.tar.gz
gentoo-2ab1d293f6a880b9111284c26e7e71458604fa30.tar.bz2
gentoo-2ab1d293f6a880b9111284c26e7e71458604fa30.zip
sys-devel/llvm: Bump to 3.9.0rc3
Diffstat (limited to 'sys-devel/llvm/llvm-3.8.1-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.8.1-r2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-devel/llvm/llvm-3.8.1-r2.ebuild b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
index cbead1dacfe4..de892fd0b38e 100644
--- a/sys-devel/llvm/llvm-3.8.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
@@ -145,7 +145,7 @@ src_prepare() {
# Fix libdir for ocaml bindings install, bug #559134
eapply "${FILESDIR}"/9999/0001-cmake-Install-OCaml-modules-into-correct-package-loc.patch
# Do not build/install ocaml docs with USE=-doc, bug #562008
- eapply "${FILESDIR}"/3.8.1/0002-cmake-Make-OCaml-docs-dependent-on-LLVM_BUILD_DOCS.patch
+ eapply "${FILESDIR}"/3.9.0/0002-cmake-Make-OCaml-docs-dependent-on-LLVM_BUILD_DOCS.patch
# Make it possible to override Sphinx HTML install dirs
# https://llvm.org/bugs/show_bug.cgi?id=23780
@@ -164,7 +164,7 @@ src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
- eapply "${FILESDIR}"/3.8.1/llvm-config-r1.patch
+ eapply "${FILESDIR}"/3.9.0/llvm-config-r1.patch
# Restore SOVERSIONs for shared libraries
# https://bugs.gentoo.org/show_bug.cgi?id=578392
@@ -184,13 +184,13 @@ src_prepare() {
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- eapply "${FILESDIR}"/3.8.1/clang/gentoo-runtime-gcc-detection-v3.patch
+ eapply "${FILESDIR}"/3.9.0/clang/gentoo-runtime-gcc-detection-v3.patch
# Support gcc4.9 search paths
# https://github.com/llvm-mirror/clang/commit/af4db76e059c1a3
eapply "${FILESDIR}"/3.8.1/clang/gcc4.9-search-path.patch
- eapply "${FILESDIR}"/3.8.1/clang/darwin_prefix-include-paths.patch
+ eapply "${FILESDIR}"/3.9.0/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
pushd "${S}"/tools/clang >/dev/null || die
@@ -206,7 +206,7 @@ src_prepare() {
# Install clang runtime into /usr/lib/clang
# https://llvm.org/bugs/show_bug.cgi?id=23792
- eapply "${FILESDIR}"/3.8.1/clang/0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
+ eapply "${FILESDIR}"/3.9.0/clang/0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
eapply "${FILESDIR}"/3.8.1/compiler-rt/0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
# Do not force -march flags on arm platforms
@@ -216,7 +216,7 @@ src_prepare() {
# Make it possible to override CLANG_LIBDIR_SUFFIX
# (that is used only to find LLVMgold.so)
# https://llvm.org/bugs/show_bug.cgi?id=23793
- eapply "${FILESDIR}"/3.8.1/clang/0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+ eapply "${FILESDIR}"/3.9.0/clang/0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
# Fix git-clang-format shebang, bug #562688
python_fix_shebang tools/clang/tools/clang-format/git-clang-format
@@ -245,7 +245,7 @@ src_prepare() {
sed -e 's/add_subdirectory(readline)/#&/' \
-i tools/lldb/scripts/Python/modules/CMakeLists.txt || die
# Do not install bundled six module
- eapply "${FILESDIR}"/3.8.1/lldb/six.patch
+ eapply "${FILESDIR}"/3.9.0/lldb/six.patch
fi
# User patches