summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-06 08:42:33 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-06 14:47:54 +0200
commit9f28a19a757b5ad8c901a62d10648a8e65e6bd15 (patch)
tree7a8f531968db33482a7ab273ed998196d5eaa690 /sys-devel/llvm
parentwww-servers/uwsgi: add gevent python3 support fixes #597022 (diff)
downloadgentoo-9f28a19a757b5ad8c901a62d10648a8e65e6bd15.tar.gz
gentoo-9f28a19a757b5ad8c901a62d10648a8e65e6bd15.tar.bz2
gentoo-9f28a19a757b5ad8c901a62d10648a8e65e6bd15.zip
sys-devel/llvm: Include MANPATH in env.d file
Include MANPATH in the env.d file so that 'man' can reliably find all the manpages. It seems that at least sys-apps/man-db can still find the manpages relative to the tools found in PATH but that is most likely unreliable.
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-4.0.0-r1.ebuild (renamed from sys-devel/llvm/llvm-4.0.0.ebuild)1
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-4.0.0.ebuild b/sys-devel/llvm/llvm-4.0.0-r1.ebuild
index f7f8e7c7456e..1384df1a1191 100644
--- a/sys-devel/llvm/llvm-4.0.0.ebuild
+++ b/sys-devel/llvm/llvm-4.0.0-r1.ebuild
@@ -258,6 +258,7 @@ multilib_src_install_all() {
PATH="${EPREFIX}/usr/lib/llvm/${SLOT}/bin"
# we need to duplicate it in ROOTPATH for Portage to respect...
ROOTPATH="${EPREFIX}/usr/lib/llvm/${SLOT}/bin"
+ MANPATH="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
LDPATH="$( IFS=:; echo "${LLVM_LDPATHS[*]}" )"
_EOF_
doenvd "${T}/10llvm-${revord}"
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index cdba7b1daf4e..16413680bdfe 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -258,6 +258,7 @@ multilib_src_install_all() {
PATH="${EPREFIX}/usr/lib/llvm/${SLOT}/bin"
# we need to duplicate it in ROOTPATH for Portage to respect...
ROOTPATH="${EPREFIX}/usr/lib/llvm/${SLOT}/bin"
+ MANPATH="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
LDPATH="$( IFS=:; echo "${LLVM_LDPATHS[*]}" )"
_EOF_
doenvd "${T}/10llvm-${revord}"