summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-10-14 00:00:00 +0000
committerMichał Górny <mgorny@gentoo.org>2020-10-14 23:14:18 +0200
commitf349dc5fa5c76931e9a8629edfaa9054fed2f37f (patch)
tree3b9b855107437e099862536ac454de8865727e5e /sys-devel/llvm
parentdev-python/python-lhafile: Don't depend on dev-python/setuptools (diff)
downloadgentoo-f349dc5fa5c76931e9a8629edfaa9054fed2f37f.tar.gz
gentoo-f349dc5fa5c76931e9a8629edfaa9054fed2f37f.tar.bz2
gentoo-f349dc5fa5c76931e9a8629edfaa9054fed2f37f.zip
sys-devel/llvm: Set used Python interpreter.
Required since: https://github.com/llvm/llvm-project/commit/c4c3883b00d3a6aa657a5e3e515c90c9ea1f81c6 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild3
-rw-r--r--sys-devel/llvm/llvm-11.0.0.ebuild3
-rw-r--r--sys-devel/llvm/llvm-12.0.0.9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index 6ee898821d6b..fd13357643c7 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -53,6 +53,7 @@ DEPEND="${RDEPEND}
gold? ( sys-libs/binutils-libs )"
BDEPEND="
dev-lang/perl
+ >=dev-util/cmake-3.16
sys-devel/gnuconfig
kernel_Darwin? (
<sys-libs/libcxx-$(ver_cut 1-3).9999
@@ -362,6 +363,8 @@ multilib_src_configure() {
# used only for llvm-objdump tool
-DHAVE_LIBXAR=$(multilib_native_usex xar 1 0)
+ -DPython3_EXECUTABLE="${PYTHON}"
+
# disable OCaml bindings (now in dev-ml/llvm-ocaml)
-DOCAMLFIND=NO
)
diff --git a/sys-devel/llvm/llvm-11.0.0.ebuild b/sys-devel/llvm/llvm-11.0.0.ebuild
index a1a38d4cbd26..1a9eb3f64061 100644
--- a/sys-devel/llvm/llvm-11.0.0.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.ebuild
@@ -53,6 +53,7 @@ DEPEND="${RDEPEND}
gold? ( sys-libs/binutils-libs )"
BDEPEND="
dev-lang/perl
+ >=dev-util/cmake-3.16
sys-devel/gnuconfig
kernel_Darwin? (
<sys-libs/libcxx-$(ver_cut 1-3).9999
@@ -362,6 +363,8 @@ multilib_src_configure() {
# used only for llvm-objdump tool
-DHAVE_LIBXAR=$(multilib_native_usex xar 1 0)
+ -DPython3_EXECUTABLE="${PYTHON}"
+
# disable OCaml bindings (now in dev-ml/llvm-ocaml)
-DOCAMLFIND=NO
)
diff --git a/sys-devel/llvm/llvm-12.0.0.9999.ebuild b/sys-devel/llvm/llvm-12.0.0.9999.ebuild
index 9f6248bfa037..9c432a044b6c 100644
--- a/sys-devel/llvm/llvm-12.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-12.0.0.9999.ebuild
@@ -53,6 +53,7 @@ DEPEND="${RDEPEND}
gold? ( sys-libs/binutils-libs )"
BDEPEND="
dev-lang/perl
+ >=dev-util/cmake-3.16
sys-devel/gnuconfig
kernel_Darwin? (
<sys-libs/libcxx-$(ver_cut 1-3).9999
@@ -363,6 +364,8 @@ multilib_src_configure() {
# used only for llvm-objdump tool
-DHAVE_LIBXAR=$(multilib_native_usex xar 1 0)
+ -DPython3_EXECUTABLE="${PYTHON}"
+
# disable OCaml bindings (now in dev-ml/llvm-ocaml)
-DOCAMLFIND=NO
)