summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-13 02:27:39 +0000
committerSam James <sam@gentoo.org>2023-11-13 02:27:40 +0000
commitcc039c0c2365fd938bdd755f1f3afa1c7d49643c (patch)
tree1dbcda033d18f56c1638c05181b3f0f20ea295f4 /sys-devel/mold
parentprofiles/arch/sparc/32ul: mask mold on sparc32 (diff)
downloadgentoo-cc039c0c2365fd938bdd755f1f3afa1c7d49643c.tar.gz
gentoo-cc039c0c2365fd938bdd755f1f3afa1c7d49643c.tar.bz2
gentoo-cc039c0c2365fd938bdd755f1f3afa1c7d49643c.zip
sys-devel/mold: use dosym -r, sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/mold')
-rw-r--r--sys-devel/mold/mold-2.3.2-r1.ebuild2
-rw-r--r--sys-devel/mold/mold-9999.ebuild3
2 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/mold/mold-2.3.2-r1.ebuild b/sys-devel/mold/mold-2.3.2-r1.ebuild
index 26a184843d8c..1ff59907edb2 100644
--- a/sys-devel/mold/mold-2.3.2-r1.ebuild
+++ b/sys-devel/mold/mold-2.3.2-r1.ebuild
@@ -92,5 +92,5 @@ src_install() {
dosym ${PN} /usr/bin/ld.${PN}
dosym ${PN} /usr/bin/ld64.${PN}
- dosym ../../../usr/bin/${PN} /usr/libexec/${PN}/ld
+ dosym -r /usr/bin/${PN} /usr/libexec/${PN}/ld
}
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index f16aabe0758e..f602c3b96e96 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -72,6 +72,7 @@ src_configure() {
-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON
-DMOLD_ENABLE_QEMU_TESTS=OFF
-DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
+ -DMOLD_USE_MIMALLOC=$(usex !kernel_Darwin)
-DMOLD_USE_SYSTEM_MIMALLOC=ON
-DMOLD_USE_SYSTEM_TBB=ON
)
@@ -90,5 +91,5 @@ src_install() {
dosym ${PN} /usr/bin/ld.${PN}
dosym ${PN} /usr/bin/ld64.${PN}
- dosym ../../../usr/bin/${PN} /usr/libexec/${PN}/ld
+ dosym -r /usr/bin/${PN} /usr/libexec/${PN}/ld
}