summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-02-01 05:51:45 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-02-24 14:14:26 +0200
commitf8089f372d8d22aaed084fe960bfa572401d8fc4 (patch)
tree7b458985311db9a2f30052a902dca87109c47294 /sys-devel/qbe/qbe-1.1.ebuild
parentapp-text/libpaper: add 2.0.10 (diff)
downloadgentoo-f8089f372d8d22aaed084fe960bfa572401d8fc4.tar.gz
gentoo-f8089f372d8d22aaed084fe960bfa572401d8fc4.tar.bz2
gentoo-f8089f372d8d22aaed084fe960bfa572401d8fc4.zip
sys-devel/qbe: add 1.1
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/29367 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-devel/qbe/qbe-1.1.ebuild')
-rw-r--r--sys-devel/qbe/qbe-1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/qbe/qbe-1.1.ebuild b/sys-devel/qbe/qbe-1.1.ebuild
new file mode 100644
index 000000000000..c32cbd4d13b6
--- /dev/null
+++ b/sys-devel/qbe/qbe-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="git://c9x.me/qbe.git"
+ inherit git-r3
+else
+ SRC_URI="https://c9x.me/compile/release/${P}.tar.xz"
+
+ # 64-bit RISC-V only
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+DESCRIPTION="Pure-C embeddable compiler backend"
+HOMEPAGE="https://c9x.me/compile/"
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( README doc )
+
+src_compile() {
+ tc-export CC
+
+ emake CFLAGS="-std=c99 ${CPPFLAGS} ${CFLAGS}"
+}
+
+src_install() {
+ einstalldocs
+ emake install DESTDIR="${ED}" PREFIX=/usr
+}