summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-27 10:42:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-27 13:10:29 +0100
commit0c131285fe2232ae7e53bc561d0d11bbb761c6a4 (patch)
treec2763d6f71ab6d5257756a08ba2e7e89a5296df3 /sys-devel
parentdev-ruby/pg: apply upstream fix for x86 (diff)
downloadgentoo-0c131285fe2232ae7e53bc561d0d11bbb761c6a4.tar.gz
gentoo-0c131285fe2232ae7e53bc561d0d11bbb761c6a4.tar.bz2
gentoo-0c131285fe2232ae7e53bc561d0d11bbb761c6a4.zip
sys-devel/llvm: Install LLVMDebuginfod static library for lldb
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-19.0.0.9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-19.0.0.9999.ebuild b/sys-devel/llvm/llvm-19.0.0.9999.ebuild
index 9c1e247877cc..a0c0d6fa41d6 100644
--- a/sys-devel/llvm/llvm-19.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-19.0.0.9999.ebuild
@@ -128,6 +128,9 @@ check_distribution_components() {
# TableGen lib + deps
LLVMDemangle|LLVMSupport|LLVMTableGen)
;;
+ # used by lldb
+ LLVMDebuginfod)
+ ;;
# testing libraries
LLVMTestingAnnotations|LLVMTestingSupport)
;;
@@ -217,6 +220,9 @@ get_distribution_components() {
if multilib_is_native_abi; then
out+=(
+ # library used by lldb
+ LLVMDebuginfod
+
# utilities
llvm-tblgen
FileCheck