summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-23 08:35:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-23 12:00:24 +0200
commit79e35e6dd5867e42d2ca0705794fff65d8745ec7 (patch)
tree86b9f8ca9d8d5bbd4a54b47d2d000acf4a9471ac /sys-devel
parentdev-python/urllib3: Bump to 1.25.10 (diff)
downloadgentoo-79e35e6dd5867e42d2ca0705794fff65d8745ec7.tar.gz
gentoo-79e35e6dd5867e42d2ca0705794fff65d8745ec7.tar.bz2
gentoo-79e35e6dd5867e42d2ca0705794fff65d8745ec7.zip
sys-devel/llvm: Build only distribution targets in src_compile()
Build only distribution targets rather than everything. Most importantly, this fixes the build failure due to trying to build HTML docs when sphinx is available but recommonmark is not. As a side result, this may prevent some unnecessary targets from being built and delay some others into src_test(). Closes: https://bugs.gentoo.org/730268 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild2
-rw-r--r--sys-devel/llvm/llvm-12.0.0.9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index d0bcbd3665f3..6ee898821d6b 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -435,7 +435,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- cmake_src_compile
+ cmake_build distribution
pax-mark m "${BUILD_DIR}"/bin/llvm-rtdyld
pax-mark m "${BUILD_DIR}"/bin/lli
diff --git a/sys-devel/llvm/llvm-12.0.0.9999.ebuild b/sys-devel/llvm/llvm-12.0.0.9999.ebuild
index d0bcbd3665f3..6ee898821d6b 100644
--- a/sys-devel/llvm/llvm-12.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-12.0.0.9999.ebuild
@@ -435,7 +435,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- cmake_src_compile
+ cmake_build distribution
pax-mark m "${BUILD_DIR}"/bin/llvm-rtdyld
pax-mark m "${BUILD_DIR}"/bin/lli