summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-08 11:26:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-08 11:36:14 +0200
commit9684c6f55dac92d5d17946563c861f87b6ce576b (patch)
tree4e01b1c0971557c35e183084d0585669dd3f391b /sys-devel
parentmail-mta/postfix: add linux-6 support (diff)
downloadgentoo-9684c6f55dac92d5d17946563c861f87b6ce576b.tar.gz
gentoo-9684c6f55dac92d5d17946563c861f87b6ce576b.tar.bz2
gentoo-9684c6f55dac92d5d17946563c861f87b6ce576b.zip
sys-devel/clang-common: Depend on compiler-rt via clang-runtime
Depend on sys-devel/clang-runtime[compiler-rt] rather than on sys-libs/compiler-rt directly. Since compiler-rt is slotted while sys-devel/clang-common is not, it is impossible to guarantee that a compiler-rt version matching all installed sys-devel/clang versions will be installed. While depending on clang-runtime does not strictly solve this either, enforcing a USE dependency has a good chance of having the user enable USE=compiler-rt on all versions of clang-runtime, and then clang-runtime dep in sys-devel/clang will enforce the correct compiler-rt version. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.2.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-15.0.2.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild b/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild
index 617e3159ca14..e318815568c5 100644
--- a/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild
@@ -16,7 +16,7 @@ IUSE="default-compiler-rt default-libcxx default-lld llvm-libunwind"
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- =sys-libs/compiler-rt-${LLVM_VERSION}*
+ sys-devel/clang-runtime[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind )
!llvm-libunwind? ( sys-libs/libunwind )
)
diff --git a/sys-devel/clang-common/clang-common-15.0.2.ebuild b/sys-devel/clang-common/clang-common-15.0.2.ebuild
index a8fa6ec6070f..71e8aa15b6d8 100644
--- a/sys-devel/clang-common/clang-common-15.0.2.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.2.ebuild
@@ -16,7 +16,7 @@ IUSE="default-compiler-rt default-libcxx default-lld llvm-libunwind"
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- =sys-libs/compiler-rt-${PV%_*}*
+ sys-devel/clang-runtime[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind )
!llvm-libunwind? ( sys-libs/libunwind )
)
diff --git a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
index 617e3159ca14..e318815568c5 100644
--- a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
@@ -16,7 +16,7 @@ IUSE="default-compiler-rt default-libcxx default-lld llvm-libunwind"
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- =sys-libs/compiler-rt-${LLVM_VERSION}*
+ sys-devel/clang-runtime[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind )
!llvm-libunwind? ( sys-libs/libunwind )
)
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild
index 617e3159ca14..e318815568c5 100644
--- a/sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild
@@ -16,7 +16,7 @@ IUSE="default-compiler-rt default-libcxx default-lld llvm-libunwind"
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- =sys-libs/compiler-rt-${LLVM_VERSION}*
+ sys-devel/clang-runtime[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind )
!llvm-libunwind? ( sys-libs/libunwind )
)