summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-03 01:00:41 +0100
committerSam James <sam@gentoo.org>2022-05-03 01:00:52 +0100
commita13326cd6745d107527beec8bc0d4fba09ab1cfb (patch)
treeac2e062487c11f279bd98e1754e0f82e8fd9467d /sys-devel
parentdev-libs/boehm-gc: fix missing installed headers for 8.2.0 (diff)
downloadgentoo-a13326cd6745d107527beec8bc0d4fba09ab1cfb.tar.gz
gentoo-a13326cd6745d107527beec8bc0d4fba09ab1cfb.tar.bz2
gentoo-a13326cd6745d107527beec8bc0d4fba09ab1cfb.zip
sys-devel/gdb: fix build with sys-libs/readline-8.2*
Closes: https://bugs.gentoo.org/842252 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/files/gdb-12.1-readline-8.2-build.patch29
-rw-r--r--sys-devel/gdb/gdb-12.1.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-devel/gdb/files/gdb-12.1-readline-8.2-build.patch b/sys-devel/gdb/files/gdb-12.1-readline-8.2-build.patch
new file mode 100644
index 000000000000..fad27ee4ca85
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-12.1-readline-8.2-build.patch
@@ -0,0 +1,29 @@
+https://sourceware.org/git/?p=binutils-gdb.git;a=patch;h=1add37b567a7dee39d99f37b37802034c3fce9c4
+https://bugs.gentoo.org/842252
+
+From: Andreas Schwab <schwab@linux-m68k.org>
+Date: Sun, 20 Mar 2022 14:01:54 +0100
+Subject: [PATCH] Add support for readline 8.2
+
+In readline 8.2 the type of rl_completer_word_break_characters changed to
+include const.
+--- a/gdb/completer.c
++++ b/gdb/completer.c
+@@ -36,7 +36,7 @@
+ calling a hook instead so we eliminate the CLI dependency. */
+ #include "gdbcmd.h"
+
+-/* Needed for rl_completer_word_break_characters() and for
++/* Needed for rl_completer_word_break_characters and for
+ rl_filename_completion_function. */
+ #include "readline/readline.h"
+
+@@ -2011,7 +2011,7 @@ gdb_completion_word_break_characters_throw ()
+ rl_basic_quote_characters = NULL;
+ }
+
+- return rl_completer_word_break_characters;
++ return (char *) rl_completer_word_break_characters;
+ }
+
+ char *
diff --git a/sys-devel/gdb/gdb-12.1.ebuild b/sys-devel/gdb/gdb-12.1.ebuild
index 8e18279f8752..b7ca1edd1937 100644
--- a/sys-devel/gdb/gdb-12.1.ebuild
+++ b/sys-devel/gdb/gdb-12.1.ebuild
@@ -93,6 +93,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
+ "${FILESDIR}"/${P}-readline-8.2-build.patch
)
pkg_setup() {