summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 17:06:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 18:55:26 +0200
commitc41a3115e0c607611cf3db88bab5226d5bd77d7b (patch)
treea5f7e11482353e9d868a3441894d8f618b1f23fa /sys-devel
parentsys-devel/clang-toolchain-symlinks: Add for LLVM 14.x (diff)
downloadgentoo-c41a3115e0c607611cf3db88bab5226d5bd77d7b.tar.gz
gentoo-c41a3115e0c607611cf3db88bab5226d5bd77d7b.tar.bz2
gentoo-c41a3115e0c607611cf3db88bab5226d5bd77d7b.zip
sys-devel/lld-toolchain-symlinks: Add for LLVM 14.x
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14.ebuild
new file mode 100644
index 000000000000..75ee3dd007f7
--- /dev/null
+++ b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Symlinks to use LLD on binutils-free system"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+native-symlinks"
+
+RDEPEND="
+ sys-devel/lld
+"
+
+src_install() {
+ use native-symlinks || return
+
+ local abi
+ local dest=/usr/lib/llvm/${SLOT}/bin
+ dodir "${dest}"
+ dosym ../../../../bin/ld.lld "${dest}/ld"
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+ dosym ../../../../bin/ld.lld "${dest}/${abi_chost}-ld"
+ done
+}