summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-firmware/sgabios/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-firmware/sgabios/files')
-rw-r--r--sys-firmware/sgabios/files/sgabios-0.1_pre8-build-cc.patch23
-rw-r--r--sys-firmware/sgabios/files/sgabios-0.1_pre8-makefile.patch12
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-firmware/sgabios/files/sgabios-0.1_pre8-build-cc.patch b/sys-firmware/sgabios/files/sgabios-0.1_pre8-build-cc.patch
new file mode 100644
index 000000000000..6cdac84c6acb
--- /dev/null
+++ b/sys-firmware/sgabios/files/sgabios-0.1_pre8-build-cc.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/552280
+
+--- a/Makefile
++++ b/Makefile
+@@ -20,6 +20,9 @@
+ BUILD_USER = \"$(shell whoami)\"
+
+ CFLAGS := -Wall -Os -m32 -nostdlib
++BUILD_CFLAGS := -Wall -O2
++BUILD_CC ?= $(CC)
++BUILD_LD ?= $(BUILD_CC)
+
+ ASFLAGS := $(CFLAGS)
+ ASFLAGS += -DBUILD_DATE="$(BUILD_DATE)"
+@@ -55,7 +56,7 @@
+ $(LD) $(LDFLAGS) $(OBJS) -o $@
+
+ csum8: csum8.c
+- $(CC) -Wall -O2 -o $@ $<
++ $(BUILD_CC) $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) -o $@ $<
+
+ sgabios.o: buildinfo
+
diff --git a/sys-firmware/sgabios/files/sgabios-0.1_pre8-makefile.patch b/sys-firmware/sgabios/files/sgabios-0.1_pre8-makefile.patch
new file mode 100644
index 000000000000..18e636f4e88e
--- /dev/null
+++ b/sys-firmware/sgabios/files/sgabios-0.1_pre8-makefile.patch
@@ -0,0 +1,12 @@
+diff -u sgabios-0.1_pre8/Makefile sgabios-0.1_pre8-fix//Makefile
+--- sgabios-0.1_pre8/Makefile 2012-07-21 17:16:41.903363117 -0500
++++ sgabios-0.1_pre8-fix//Makefile 2012-07-23 11:11:08.438162997 -0500
+@@ -71,8 +71,4 @@
+
+ ifeq (.depend, $(wildcard .depend))
+ include .depend
+-else
+-# if no .depend file existed, add a make clean to the end of building .depend
+-.depend::
+- $(MAKE) clean
+ endif