summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-29 14:08:18 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-29 14:08:50 -0400
commitcd75419652c1bf99cc56dc21f1d7fced9ba68a3e (patch)
treedb77ebda3e5b4b190fba1dbd42df20a13db0922a /sys-firmware/sof-firmware
parentdev-python/rdflib: Bump to 6.2.0 (diff)
downloadgentoo-cd75419652c1bf99cc56dc21f1d7fced9ba68a3e.tar.gz
gentoo-cd75419652c1bf99cc56dc21f1d7fced9ba68a3e.tar.bz2
gentoo-cd75419652c1bf99cc56dc21f1d7fced9ba68a3e.zip
sys-firmware/sof-firmware: Version bump to 2.2
Closes: https://bugs.gentoo.org/856268 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-firmware/sof-firmware')
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index fe63b1dc47c6..a3820bcbd29c 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,2 +1,3 @@
DIST sof-firmware-1.9.3.tar.gz 3710193 BLAKE2B d52fe0660c73c8e76fb60c492abe19f9e64b3064441880b84488193aa66710e49ef022c7cd1b8ece69d010aa5e416fbf4307a9c92d823525dbdc734194b0a98f SHA512 0c04bf47ecf65d3352b730e79968cb020211c274f64a3cc21e4c5e49c5a9706ab4d541aaea931e72c1bcc67fcde6387bc6bf952a33691aaab06e6b93aa73a024
DIST sof-firmware-2.1.1.tar.gz 4056718 BLAKE2B 0246f6240504d3e8b609b402c41ffe6ed9b8350b6a31c6567851069354e5de5b4ca6d803e78fdde77cdaba7be87c8a8923b2d0fdd0544fd3b28d1e332cd59b63 SHA512 77e9562f67014d78b213fe428edef6a08dcc058a9a762da09a486c002c3aa0b907ea7c8ba6d4f88f5ddab5e564de06df9f2ed77206341a0fe2e1aaab1d9740ce
+DIST sof-firmware-2.2.tar.gz 4211499 BLAKE2B c0ab39cba3ef3dd19b67d714b5a4e5a6a6cb3e8fb2d290c3fceadeb3f7dd96db986411184e16bca56bdd1905a697f8d416cd4aa5bdff90fe32e96713ff87bb71 SHA512 3cd06f6b8f8d6c3379b987cffa019a0d84263b8e00de40c18516c3e90745d5e150bdf71a8005b1ba704e44bf84d7030195e9c0ebfcd6e35228f4c14e9290cd95
diff --git a/sys-firmware/sof-firmware/sof-firmware-2.2.ebuild b/sys-firmware/sof-firmware/sof-firmware-2.2.ebuild
new file mode 100644
index 000000000000..b51c9026bd32
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-v${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Needed for sof-ctl
+RDEPEND="media-libs/alsa-lib"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" v${PV} || die
+}
+
+pkg_preinst() {
+ local sofpath="${EROOT}/lib/firmware/intel/sof"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}